Any install that I'm trying through the Software Center is telling me:

Requires installation of untrusted packages: The action would require the installation of packages from not authenticated sources.

I did an apt-get update from the command line, then removed the software sources that the keys were bad from (PPAs I added myself), and unchecked them in the software sources for software center, but to no avail. I can't install anything from software center anymore - only> from the command line with apt-get.

Is uninstalling/installing the only option? I don't want to break other PPAs that I have.

Additional information:

Here's a paste from apt-get update:

Reading package lists... Done
W: GPG error: http://ppa.launchpad.net oneiric Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B725097B3ACC3965
W: GPG error: http://us.archive.ubuntu.com oneiric Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <[email protected]>

I've tried apt-key update, and there was no effect (two keys unchanged).

The output of apt-get update and apt-get upgrade, and the contents of /etc/apt/sources.list, can be found in this pastebin post.

  • please add the full output of cat /etc/apt/sources.list as well as sudo apt-get update && sudo apt-get upgrade
    – fossfreedom
    Commented Dec 6, 2011 at 17:01
  • 1
    Might help: askubuntu.com/questions/36507/gpg-public-key-error-message Commented Dec 6, 2011 at 17:22
  • Had to snip some output because I hit the body limit. Commented Dec 6, 2011 at 18:12
  • If you use the Muon Update Manager instead, it allows you to override warnings about unsigned packages, rather like the standard update manager did in version prior to 10.04.
    – user77363
    Commented Jul 16, 2012 at 14:27

4 Answers 4


Open the Terminal and enter the commands below one by one:

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update

Update: This might not help in some later versions, which might require alternative solutions like the one in the other answer, or this one that seems to do the job in some cases under Ubuntu 16.04:

sudo apt-get update
sudo apt-get dist-upgrade
  • 18
    Thanks, but why is this required of the user, the ubuntu system updater should really try to "do the right thing" Commented Jun 1, 2012 at 16:59
  • 5
    Solved the problem! @Sadi could you please explain what is happening behind the scenes? Were some of the keys outdated or what? Commented Jul 14, 2012 at 13:42
  • 1
    this works BUT depending on the country where you are, you MIIGHT get a "SOMETHING WICKED HAPPENED" while updating, indicating that there might be a SOFTWARE SOURCES problem with ubuntu software center (or synaptics). in that case, change from your country's server to main server (ubuntu software center > edit tab > software sources)
    – tony gil
    Commented Dec 6, 2012 at 1:32
  • 2
    please refer to @Tom Brossman answer, it is much better one
    – sepisoad
    Commented Dec 10, 2012 at 11:57
  • 2
    This did not work for me. Commented Jan 13, 2016 at 20:43

This is a common problem with Launchpad PPAs. Common enough that I've copied these commands to use when I reinstall or add new Launchpad PPAs.

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys  


sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys YOURKEYNUMBERHERE  

Substitute YOURKEYNUMBERHERE with the problem keys, like this:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B725097B3ACC3965  


sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5  

The first line is almost the same, minus the keys. It might even be optional, I honestly don't know. All I am sure of is that this method always fixes the problem immediately.

If anyone finds the original answer that I copied these from let me know and I'll link to it and give them the attribution.

**EDIT It's almost certainly karthik87's answer here or here I got this from. This can probably be closed as a duplicate.

Either way, don't forget to do a

sudo apt-get update  

after, to fix everything.

Note: Running apt-get update first should give you an error message mentioning which key is missing and an ID to be used with the apt-key command.

  • This didn't work for me.. When I try to receive the keys, it show total number processed: 1, and unchanged: also 1. nothing changes.
    – Starx
    Commented Feb 7, 2012 at 7:21
  • @Starx You might be better off copying your specific error message into a search engine, or posting it here as a new question. Also, take a look at the Related Questions in the sidebar to the right. There are a lot of problems similar to this, and several different solutions. Sorry I can't be more help. Commented Feb 7, 2012 at 9:28
  • I have posted a question here. Please see it
    – Starx
    Commented Feb 7, 2012 at 10:17
  • @TomBrossman I was able to repair the GPG error using your method without the first line.
    – Mario
    Commented Nov 6, 2013 at 23:12
  • Works for me, thx! In addition you should check what apt-get update outputs in the end. E.g. Duplicate sources.list , Failed to fetch. You should resolve there errors before updates. You can disable/remove failed and duplicated sources in Software & Updates application at the Other Software tab.
    – milkovsky
    Commented Jan 8, 2016 at 9:30

Maybe you could try changing to Main Server in Software Sources, where it says Download from.


Requires installation of untrusted packages: The action would require the installation of packages from not authenticated sources.

I received this error from the Ubuntu Software Updater after adding a repository without adding the key for the repository. Some software repositories are good about giving you instructions on how to add their repository keys along with the instructions to add the repository, like Launchpad.Others just give you the key.

To figure out what key you need in a terminal run:

sudo apt-get update

This will download the list of available packages from your repositories which uses the keys. If a key is missing it will return an error message.

Use the information in the error message to find and download the key then add it to your apt keyring with:

sudo apt-key add /PathToTheKeyFile/KeyFile.gpg

You should get back an OK. Now to test that you have all the needed repository authentication keys to allow the Ubuntu Software Updater to run:

sudo apt-get update

This will again download the list of available packages from your repositories which uses the keys. If a key is missing it will return an error message.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .