2

After solving this problem, I have a second one. It appears to play now, according to Gnome Music Player Client (gmpc), but there's no sound. My /etc/mpd.conf so far has this in it:

audio_output {
       type            "alsa"
       name            "XR18"
       device          "plughw:CARD=X18XR18,DEV=0"
       format          "48000:32:2"
       auto_resample   "no"            # make MPD resample, instead of ALSA's libasound
       auto_channels   "no"            # play a multi-track audio file on its specified channels, no remapping
       always_on       "yes"           # keep the output device open, even when not playing
       mixer_type      "software"      # don't look for a hardware mixer because this card doesn't have one (at least not from the PC side)
#       mixer_device    "default"       # optional
#       mixer_control   "PCM"           # optional
#       mixer_index     "0"             # optional
}

With the default mixer_type "hardware", gmpc appeared to be muted, and wouldn't allow me to unmute. The mute command (Ctrl+space, then type mute) did this:

enter image description here

Changing to mixer_type "software" got me a GUI volume control, but still no sound. If I call it like this in my startup script, which itself gets called from rc.local:

mpd >> "$REC_PATH/Debug.log" 2>&1 &

then I get this in Debug.log:

socket: Failed to bind to '[::]:6600': Address already in use

I'm not sure what else would use that though. gmpc connects anyway. aplay with the first level of verbosity does this:

audiohub@DYM-Portable-AudioHub:~$ aplay -v -D plughw:X18XR18 "/home/audiohub/Music/Waterlines/05 - Take Your Time.wav"
Playing WAVE '/home/audiohub/Music/Waterlines/05 - Take Your Time.wav' : Float 32 bit Little Endian, Rate 44100 Hz, Stereo
Plug PCM: Linear Integer <-> Linear Float conversion PCM (S32_LE)
Its setup is:
  stream       : PLAYBACK
  access       : RW_INTERLEAVED
  format       : FLOAT_LE
  subformat    : STD
  channels     : 2
  rate         : 44100
  exact rate   : 44100 (44100/1)
  msbits       : 32
  buffer_size  : 13379
  period_size  : 3345
  period_time  : 75854
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 3345
  period_event : 0
  start_threshold  : 13379
  stop_threshold   : 13379
  silence_threshold: 0
  silence_size : 0
  boundary     : 1753612288
Slave: Rate conversion PCM (48000, sformat=S32_LE)
Converter: linear-interpolation
Protocol version: 10002
Its setup is:
  stream       : PLAYBACK
  access       : MMAP_INTERLEAVED
  format       : S32_LE
  subformat    : STD
  channels     : 2
  rate         : 44100
  exact rate   : 44100 (44100/1)
  msbits       : 32
  buffer_size  : 13379
  period_size  : 3345
  period_time  : 75854
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 3345
  period_event : 0
  start_threshold  : 13379
  stop_threshold   : 13379
  silence_threshold: 0
  silence_size : 0
  boundary     : 1753612288
Slave: Route conversion PCM (sformat=S32_LE)
  Transformation table:
    0 <- 0
    1 <- 1
    2 <- none
    3 <- none
    4 <- none
    5 <- none
    6 <- none
    7 <- none
    8 <- none
    9 <- none
    10 <- none
    11 <- none
    12 <- none
    13 <- none
    14 <- none
    15 <- none
    16 <- none
    17 <- none
Its setup is:
  stream       : PLAYBACK
  access       : MMAP_INTERLEAVED
  format       : S32_LE
  subformat    : STD
  channels     : 2
  rate         : 48000
  exact rate   : 48000 (48000/1)
  msbits       : 32
  buffer_size  : 14563
  period_size  : 3641
  period_time  : 75854
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 3641
  period_event : 0
  start_threshold  : 10923
  stop_threshold   : 14563
  silence_threshold: 0
  silence_size : 0
  boundary     : 1908801536
Slave: Hardware PCM card 2 'X18/XR18' device 0 subdevice 0
Its setup is:
  stream       : PLAYBACK
  access       : MMAP_INTERLEAVED
  format       : S32_LE
  subformat    : STD
  channels     : 18
  rate         : 48000
  exact rate   : 48000 (48000/1)
  msbits       : 32
  buffer_size  : 14563
  period_size  : 3641
  period_time  : 75854
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 3641
  period_event : 0
  start_threshold  : 10923
  stop_threshold   : 14563
  silence_threshold: 0
  silence_size : 0
  boundary     : 1908801536
  appl_ptr     : 0
  hw_ptr       : 0

audiohub@DYM-Portable-AudioHub:~$ 

And I see the meters dance in the X18XR18's control app. According to alsamixer, it has no controls at all, which is fine with me because it's actually this: https://www.music-group.com/Categories/Behringer/Mixers/Digital-Mixers/XR18/p/P0BI8 So the mute, volume, and a ton of other stuff is handled on that side through the app, which is available for free in the downloads section of that site. I just want to throw audio at it.

Is there still something missing?

5
  • So aplay is able to generate sounds? What's the output of aplay -v -D plughw:X18XR18 something.wav? – CL. Dec 3 '16 at 8:43
  • @CL. It makes the meters dance today, and I heard it yesterday. I have it home now, listening to other music, so I don't have speakers hooked up to it. Updated the question. – AaronD Dec 3 '16 at 20:51
  • The "Slave: Route conversion" shows that the two stereo channels end up at the first two of the eighteen channels of the device. Which channels do you actually want to use? – CL. Dec 4 '16 at 0:03
  • @CL. It doesn't really matter. I can remap anything once it gets there. But when I play something with mpd and look at all 18 meters, nothing lights up. If all I wanted was playback, I could set it for 2/2 instead of 18/18 (another binary option in the control app). But I really want the 18-track recording as well, using different software, the details of which are probably outside the scope of this question. – AaronD Dec 4 '16 at 3:36
  • I don't know how mpd behaves for such a device (ask them), but that auto_channels setting looks suspicious. – CL. Dec 4 '16 at 10:03
0

Assumptions: You are using Ubuntu 16.04, and MPD V0.19.20.

I just found at https://www.musicpd.org/ there is a new version V0.19.21 that may fix your issue, also some issues I am having.

Good luck to both of us.

Mark.

1
  • It does indeed, now that I finally got back around to this project. It needs to be compiled from source, though. It's not in the repository so apt-get install mpd still gives the old one. – AaronD Jan 4 '17 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.