0

When you want update flash player :

sudo update-pepperflashplugin-nonfree --install

You get this :

mv: cannot stat 'unpackchrome/opt/google/chrome/PepperFlash/libpepflashplayer.so': No such file or directory
  • 1
    Why don't you edit your question, copy your topic and make it the question and move your current question as an answer? – Tony Lancer Dec 2 '16 at 23:58
  • dont underspend you, Can I answer my own question, what it change ? – Daro from Poland Dec 3 '16 at 0:06
  • I did what you suggest. – Daro from Poland Dec 3 '16 at 12:45
0

For Opera, Firefox & Chromium use this command

sudo apt-get install adobe-flashplugin

This should install the last version of Flash with latest security backports.

0

Here is solution for Opera (Chromium should work too), in shortcut after installation of pepperflashplugin-nonfree, You should do this:

Download newest adobe flash player from here unpack and select :

libpepflashplayer.so , manifest.json

and paste here :

/usr/lib/pepperflashplugin-nonfree

What I know flash player have many security issues can't be fixed because of basic assumptions. Despite the introduction of video mark in HTML 5 , no one uses this mark as main mark to distribute video stuff. Overwhelming majority of Internet portals uses still buggy flash player where not authorised code could be inject. There is no way to convince people to not use flash player , argument for this is the number of openings of these materials where one movie have over 20 millions views, then ensuring anyone that does not use flash does not matter, people don't allow for change in that way. Many people here advise to use firefox because distribution flash player inside with installation but did they know that this action is against assumptions of security ? I think there are two ways , first, allowing flash player to distribution and fighting with buggy flash player,

or second what I prefer is blocking distribution of flash player. You ask why providers of internet sites uses flash player , answer is simple they don't want security of users They want to have an impact on your systems, solution is blocking flash player until owners of www site start change code and management policy of sites, one starts the rest must adjust.

0

I tried most of the responses here and could not get pepperflashplugin to work. The final option that worked perfectly for me (ubuntu 16.10, x64) was to install official adobe flashplayer, and manually edit the file /usr/lib/x86_64-linux-gnu/opera/resources/pepper_flash_config.json to add the location of the plugin:

{
  "PepperFlashPaths" : [
    "/usr/lib/adobe-flashplugin/libpepflashplayer.so",
    "/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so",
    "/usr/lib/PepperFlash/libpepflashplayer.so",
    "/usr/lib64/PepperFlash/libpepflashplayer.so",
    "/usr/lib/chromium-browser/PepperFlash/libpepflashplayer.so",
    "/usr/lib/chromium/PepperFlash/libpepflashplayer.so",
    "/usr/lib64/chromium-browser/PepperFlash/libpepflashplayer.so",
    "/usr/lib64/chromium/PepperFlash/libpepflashplayer.so",
    "/opt/google/chrome-beta/PepperFlash/libpepflashplayer.so",
    "/opt/google/chrome-unstable/PepperFlash/libpepflashplayer.so",
    "/opt/google/chrome/PepperFlash/libpepflashplayer.so",
    "/usr/lib/flashplugin-installer/libflashplayer.so"
  ]
}

Adding this last location "/usr/lib/flashplugin-installer/libflashplayer.so" and restarting opera did the trick for me.

  • I have Opera 43.0.2442.1144 Stable, and the pepperflash plugin is located in the very first path listed in this JSON file. I still don't see the plugin in opera:plugins, nor does it actually get loaded. The .so file is owned by root and has permissions -rwxr-xr-x. What's wrong? – appas Mar 16 '17 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.