9

This question already has an answer here:

I get this message everytime I log in:

Failure to download extra data files

The following packages requested additional data downloads after package installation, but the data could not be downloaded or could not be processed.

ttf-mscorefonts-installer

The download will be attempted again later, or you can try the download again now. Running this command requires an active Internet connection.

When I try to reinstall the package, I get this error:

$ sudo apt-get install --reinstall ttf-mscorefonts-installer           

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/29,5 kB of archives.
After this operation, 0 B of additional disk space will be used.
Preconfiguring packages ...
(Reading database ... 322478 files and directories currently installed.)
Preparing to unpack .../ttf-mscorefonts-installer_3.4+nmu1ubuntu2_all.deb ...
mscorefonts-eula license has already been accepted
Unpacking ttf-mscorefonts-installer (3.4+nmu1ubuntu2) over (3.4+nmu1ubuntu2) ...
Processing triggers for fontconfig (2.11.94-0ubuntu1.1) ...
Processing triggers for update-notifier-common (3.168.2) ...
ttf-mscorefonts-installer: processing...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Err:1 http://downloads.sourceforge.net/corefonts/andale32.exe
  The HTTP server sent an invalid Content-Range header Bad header data [IP: 78.35.24.46 80]
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
E: Failed to fetch http://netcologne.dl.sourceforge.net/project/corefonts/the fonts/final/andale32.exe  The HTTP server sent an invalid Content-Range header Bad header data [IP: 78.35.24.46 80]

E: Download Failed
Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...

What could I do?

UPDATE

Seems like there is a bug about this topic: https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1645253

marked as duplicate by David Foerster, Zanna, Kevin Bowen, Eric Carvalho, Elder Geek Dec 8 '16 at 1:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • To everybody affected by this bug: Please add 'affects me too' to the bug report. It 'adds heat' and makes the developers more interested in fixing the bug. – sudodus Dec 2 '16 at 23:18
  • The bug report linked in the update of the question is a duplicate of another bug. From the discussion there, it seems that the only easy thing you can try is to do is to reattempt the download multiple times. However, I've tried it about 50 times and was not successful. There is a solution that worked for me, similar to the one suggested by @vincent-gerris. This is Solution 2 provided in this answer to another question. – mapto Dec 7 '16 at 9:45
10

There is an issue with the sourceforge downloads (mirrors and redirects being slow and/or failing). To workaround this you can grab the files manually from here for example: https://sourceforge.net/projects/corefonts/files/the%20fonts/final/ and save them in the same directory (say mscorefonts).

The files are (from the installer): Those files are in the Microsoft Windows self-installing format, and are named

andale32.exe, arial32.exe, arialb32.exe, comic32.exe, courie32.exe, georgi32.exe, impact32.exe, times32.exe, trebuc32.exe, verdan32.exe and webdin32.exe.

Make sure the package is purged and no remaining setup triggers are remaining:

sudo apt-get remove --purge ttf-mscorefonts-installer

Then in a terminal run:

sudo apt-get install ttf-mscorefonts-installer #(this will fail again most likely)
sudo dpkg-reconfigure ttf-mscorefonts-installer

That should give you a "graphical" interface in the terminal. Then point to the directory with downloaded files like /home//Downloads/mscorefonts.

Make sure no deb files are in there, the seem to be picked up too and then it fails.

That fixed it for me. I got a popup later for a post install action, I just let it run and it did not come back. Please register at launchpad and mark yourself as affected to the bug: https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1645253 so it will get more priority. Thank you.

  • this workaround worked for me, but I still haven't figured out an easy way to download a folder on sourceforge. I just did this: arrr=(andale32.exe arial32.exe arialb32.exe comic32.exe courie32.exe georgi32.exe impact32.exe times32.exe trebuc32.exe verdan32.exe webdin32.exe); for i in "${arrr[@]}"; do wget "https://sourceforge.net/projects/corefonts/files/the%20fonts/final/$i";done – Mehdi Nellen Dec 8 '16 at 13:13
  • Sprry. I tried this, and I still get the same message after reboot :( – Enrique Moreno Tent Dec 8 '16 at 18:31
  • I get all 404s for the download, and I had to change the URL. My version: arrr=(andale32.exe arial32.exe arialb32.exe comic32.exe courie32.exe georgi32.exe impact32.exe times32.exe trebuc32.exe verdan32.exe webdin32.exe); for i in "${arrr[@]}"; do wget "https://netcologne.dl.sourceforge.net/project/corefonts/the%20fonts/final/$i";done – Combuster Dec 9 '16 at 8:58
  • two months later and I I get this error again, and this method worked again. @Combuster both my script and yours don't work when I copy them from here. Typing everything manually works fine. – Mehdi Nellen Jan 26 '17 at 12:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.