0

I have a strange problem with my text editor.
A few days ago I noticed that the editor window doesn't show up, when I started the program.

Then I typed in the cli atom . inside a project folder to open it, and it worked.

But recently I've got the same issue, therefore I can't use the editor at all.

I already tried to check with ps aux|grep atom and it's shows me Atom is running, but I get no GUI.
After all I tried to kill, and restart it, but nothing changed.

Every answer will be appreciated!

3 Answers 3

1

Sometimes I have the same problem. It simply dissapear.

When I make ALT + TAB not appears Atom in the list of programs but appears another, google-chrome by example. And chosing this Atom retourning to live.

I not understand this stranger, but worked for me.

Bye!

2
  • I tried to switch between the programs with ALT + TAB, but I didn't see any Atom GUI. However your comment helped me to find the solution! Commented Dec 2, 2016 at 18:28
  • 1
    I am very happy of help you! Commented Dec 2, 2016 at 18:53
0

So apparently I just realized what happened with the editor. I didn't see any GUI when I started the program, but when I moved my mouse in a particular position I saw this.
enter image description here

And well in the middle of the picture, there is my Atom GUI somehow minimized to 1×5 pixel. After I was able to scale it out, and now works perfectly. Strange, but for now I can use it again.

1
  • 1
    happened to me too, except it was at the upper very far left by the ubuntu menu bar. I think I got there with some weird accidental key combinations. Commented May 23, 2017 at 2:58
0

I had doubts that the window might be rendered outside the screen coordinates so I used keyboard shortcuts to get Atom window snapped to cursor and move it.

For that I started Atom and pressed Alt + F7. Then the window showed up and I could position it with my mouse.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .