2

I am currently setting up a kodi PVR which is all finished apart from DVD playback.

I have ubuntu 16.04 on my desktop which I set up about a year ago and the dvds play fine on there. When I set this up I did this which has always worked.

sudo apt-get install ubuntu-restricted-extras
sudo apt-get install libdvdcss2 libdvdnav4 libdvdread4 libdvd-pkg
sudo apt-get install libdvd-pkg
sudo dpkg-reconfigure libdvd-pkg

I have repeated these steps on my PVR (even did a clean install with and without updates) and I can only play non-encrypted DVDs. (None of the ones I have purchased legally work)!

What has changed and how can I get it to work?

I installed windows 10 and libdvdcss for windows on the same hardware (both computers) and all my DVDs play fine (the ones I had time to try anyway). But I don't want to use windows! Everything else works in ubuntu just not DVDs!

I have tried two dvd drives and same problem on both (both work on my desktop PC)

0

For 14.04 (and possibly others but IDK)

Run the following commands:

$ sudo apt-get install libdvdread4
$ sudo /usr/share/doc/libdvdread4/install-css.sh

After they finishes executing, encrypted DVDs should work right away, but if they don't, try rebooting. This worked perfectly for me - before I did it, encrypted DVDs would crash the Videos program and give an error report. After, they play flawlessly.

For 16.04

Reference

Enter the following commands:

$ sudo apt install libdvdnav4 libdvdread4 gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly libdvd-pkg -y
$ sudo dpkg-reconfigure libdvd-pkg

After that you should be able to play encrypted DVDs (reboot may be necessary)

  • Hi, As I said in OP I already had livdvdread4 installed. The script you said to run does not exist. A little search suggests it does not get included in ubuntu 16.04 any more which is why I tried libdvd-pkg (with no success). All that happens is the dvd spins up then there is a black screen (in VLC and ubuntu videos app) and then the disc stops. If I put in a non-protected DVD it plays fine – Paul Dec 13 '16 at 15:03
  • Oh okay I wasn't aware that that was removed from 16.04 - I use 14.04 – cheesits456 Dec 13 '16 at 15:35
  • I edited the answer to include a method for 16.04 - I can't test it because I don't use 16.04, but I got it from a reliable source – cheesits456 Dec 13 '16 at 15:42
  • I have just set up a fresh VM of ubuntu 16.04. All I have done us install updates upgrade and dist-upgrade. When it has finished I will snapshot and try the 16.04 method and post back – Paul Dec 13 '16 at 16:54
  • OK I tried as you suggested and followed that guide exactly. No luck at all. VLC says for 3 different encrypted DVDs DVDRead could not read -1/0 blocks at 0xbb – Paul Dec 13 '16 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.