4

I am using ubuntu 16.04 on HP ProBook 440 G3. It has a finger print reader. lsusb shows this following driver

Bus 001 Device 004: ID 138a:003f Validity Sensors, Inc. VFS495 Fingerprint Reader

But Fingerprint GUI or Fprint shows no driver , as expected because 138a:003f is not in their supported list. So how can I use the fingerprint reader with ubuntu?

  • 1
    This guy managed to get it working: balintbanyasz.wordpress.com/2015/03/27/… I have not tested it on my machine though (work pc, not suitable for tests!) – Francesco Tocci Jan 18 '17 at 15:56
  • @FrancescoTocci I have tried this already. It didn't work instead it corrupted my whole os and I had to reinstall. – koushik naskar Jan 19 '17 at 15:49
  • Any updates on this? – Zia Ul Rehman Mughal Apr 28 '17 at 16:32
  • 1
    @ZiaUlRehmanMughal yes see answer. The above guide really works fine but it has some problems so see this answer instead. – Mina Michael Jun 12 '17 at 3:54
2

Instead, use the link below because you might have wrong repos. I tried it and it is working for me.

GUI FINGERPRINT SCANNER

As long as your laptop has a scanner, the above method should work

You can also try this method

Install proprietary Validity driver via terminal as below.

Download the .tar file from here on Google Drive and cd to the directory where it was saved, then run these commands:

tar xf vfs495.tar
cd vfs495
sudo apt-get install alien
sudo alien Validity-Sensor-Setup-4.5-118.00.x86_64.rpm
sudo dpkg -i validity-sensor-setup_4.5-119_amd64.deb
sudo apt-get install libssl1.0.0
sudo ln /usr/lib/x86_64-linux-gnu/libssl.so /usr/lib/libssl.so.0.9.8
sudo apt-get install libcrypto++-dev
sudo ln /usr/lib/libcryptopp.so.9 /usr/lib/libcrypto.so.0.9.8

Compile and install libfprint

mkdir libfprint
cd libfprint
rpm2cpio ../libfprint-0.0.6-18.20.1.src.rpm | cpio -i --make-directories
tar xf libfprint-0.0.6.tar.bz2
cp ../libfprint-validity.patch ./libfprint-validity.patch
cd libfprint-0.0.6/
patch -p1 < ../libfprint-validity.patch
sudo apt-get install libusb-dev libcrypto++-dev libssl-dev libglib2.0-dev libmagickcore-dev checkinstall
./configure --prefix=/usr
make
sudo checkinstall -install=no make install
sudo dpkg -i libfprint_0.0.6-1_amd64.deb

Compile and install fprint_demo

cd ../..
sudo apt-get install libgtk2.0-dev
tar xf fprint_demo-0.4.tar.bz2
cd fprint_demo-0.4
./configure --prefix=/usr
make
sudo checkinstall -install=no make install
sudo dpkg -i fprint-demo_0.4-1_amd64.deb

Finally, enroll a finger

sudo /etc/init.d/vcsFPServiceDaemon start
sudo fprint_demo

This pop-up should appear

thumbnail

Enroll your right index finger.

You should now be good to go

  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – Mr Shunz Mar 25 at 16:00
  • Got it. It's on now – N.M.Jedidiah Mar 25 at 16:22
1

You can install the driver from here. It's an rpm package so you'd need to use alien and you should also need to install other packages. Refer to this for a guide.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.