4

I have a scroll bar issue. There's a tiny pixel of margin to the right of the scroll bar, whenever I click on the scrollbar (on that margin) anywhere but not in the middle of it. The bar moves to where I clicked This is kinda annoying, any help?

Cursor Scrollbar Issue

When I hover on the scrollbar but not in the middle and click it. It kinda magnets the middle of the scrollbar to where I've clicked, another issue is that the cursor actually goes beyond the scrollbar to the right of it (a margin of around 1~2 pixels).

Scrollbar Right Margin

In this picture, I'm pointing to the right of the scrollbar, actually inside the scrollbar section. But the scrollbar is not in hover-mode However, when I click in that exact location the scrollbar scrolls to that location.

What I need to do is to remove that 1~2 pixels or margin, and turn off that scroll bar magnet problem so that when I click on any point on that seeker it doesn't scroll to the middle automatically.

  • Please edit this post, and provide screenshot of your "glitched" scrollbar. – Jim Dec 2 '16 at 11:39
  • I can't take a screenshot because the cursor is not visible, I can't elaborate the problem without the cursor in the screenshot, that's Why I didn't post it .. is there anyway to work that out? – Kareem Dec 2 '16 at 11:43
  • 1
    You can still edit your screenshots to highlight the mouse pointer position or the area described in your question. You can also use a screenshot tool that lets you include the mouse pointer in the image, e. g. Gnome Screenshot. – David Foerster Dec 2 '16 at 12:34
  • Re. the "scrollbar magnet problem", askubuntu.com/questions/774200/… may be relevant. – DK Bose Dec 2 '16 at 12:39
  • 1
    @DKBose Thank you sir very much, problem solved, it took me sometime to learn about theming and .gresource file handling, but managed to work it out at last .. Thank you very much sir :)) – Kareem Dec 2 '16 at 13:50
4

Thanks to DK Bose the problem is solve, and this is what I did..
To fix the slider magnet problem, I installed a tool called "Unity Tweak Tool"

sudo apt-get install unity-tweak-tool

Launch the app, then choose "Scrolling" from the "System" section, then choose "Legacy" option instead of the "Overlay" option in the "Scrollbars" section.

The second problem was with the "Numix" theme I'm using, the solution was to navigate to "/usr/share/themes/Numix\ Daily/" folder and make a copy of the folder on desktop and do this command:

sudo chmod -R a+rwx ~/Desktop/Numix\ Daily/*

Go inside the folder and open a folder "gtk-3.0", in that folder there's a file "gtk.gresource" and two other important files "gtk.css" and "gtk-dark.css", first extract the actual CSS code from the .gresource file using this command:

touch tempgtk.css
touch tempgtkdark.css
sudo gresource extract gtk.gresource /org/numixproject/gtk/dist/gtk.css >> tempgtk.css
sudo gresource extract gtk.gresource /org/numixproject/gtk/dist/gtk-dark.css >> tempgtkdark.css

Now open these two files "tempgtk.css" and "tempgtkdark.css" and find this line

GtkRange-trough-border

There's a value for this class, it has to be 0, if it's not 0 then set it to 0 and save.
Now open up "gtk.css" and comment/replace the content of the file with the content of "tempgtk.css", do the same for "gtk-dark.css".

Now copy those two files from the folder on your desktop, and put them back using this command:

sudo rm /usr/share/themes/Numix\ Daily/gtk-3.0/*.css
sudo cp ~/Desktop/Numix\ Daily/gtk-3.0/gtk* /usr/share/themes/Numix\ Daily/gtk-3.0/

Do a reboot or just change the theme to Ambiance and then change back to Numix and it'll work :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.