3

I can not see street names on google maps in Google Chrome!

  • Ubuntu: 14.04.4
  • Chrome: 54.0.2840.71

What i have tried so far: reinstalling chrome, resetting flags to default. Ideas?

PS There is not such problem in other browsers (e.g. Firefox) on my machine.

enter image description here enter image description here

  • Could you try disabling graphic acceleration or other features in chrome://flags/? like: Accelerated 2D canvas, Display list 2D canvas, Overlay Scrollbars, LCD text antialiasing, Distance field text. You better report this as bug report. Do you find same issue with Chromium? – user.dz Dec 6 '16 at 7:22
  • 1
    @user.dz chromium works just fine and disabling the options you listed didn't help – Dziamid Dec 6 '16 at 15:05
  • Recently I've been faced with the same problem. I was sure I did modify something accidentally, but it seems it's a general problem. – Bálint Pap Dec 8 '16 at 8:46
2
+100

Well, according these reports:
Maps not rendering street names properly
Mysterious ugly rectangles

  1. I've updated my Google Chrome and now the problem is fixed.

  2. Yesterday downloaded latest version of Chrome, today I went to maps to check something and all labels were rendering just fine - no rectangles!

  3. With the latest update they fixed this strange problem.

  4. Yesterday downloaded latest version of Chrome, today I went to maps to check something and all labels were rendering just fine - no rectangles!

As I wrote in the comments, I had the same issue, and yesterday (after the new google-chrome version update) it started to work properly.

So I'll suggest you to try to update your chrome browser, and hopefully it'll be fixed for now.

To update your actual softwares (including google-chrome), you can type:

sudo apt-get update && apt-get upgrade

Or

You can type software updater to the dash, and select like this. enter image description here

The current version what I have after the update:

google-chrome --version
Google Chrome 55.0.2883.75

I hope it helps you to solve your problem.

  • 1
    Ugly rectangles.. this is genius! Updated chrome to 55 and it worked, thanks man! – Dziamid Dec 8 '16 at 21:57
2

Maybe it's just a problem related with your current Chrome version. Try completely uninstalling that version of Chrome and installing a previous version.

You can also try updating your graphics drivers, or trying to install that version of Chrome in a Virtual Machine with your same Ubuntu version to see if it works.

0

Not really experienced in the use of WebGL but based on this post here the issue might be related to how WebGL renders its images.

So you try disabling it in google map to see it it improves, but note this affects 3D rendering and the 45o imagery.

  • I don't see a way to disable it anymore, there's no classic button present anymore i believe. Can you give more instructions please? – Dziamid Dec 8 '16 at 8:26
  • Please try this link some changes have been made to google map. Please pay attention to the your system settings – George Udosen Dec 8 '16 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.