• OS— Ubuntu 16.04 (64 bit).
  • Browser— Firefox 50.0.2.

When I go to this URL, all I see is an error message that says, "Your web browser must have JavaScript enabled in order for this site to display correctly." Yet when I go to about:config and search for "javascript.enabled", it says "true".

I have been having problems with other sites that use Javascript as well. This all started very very suddenly, just a couple of days ago. I have no idea what happened. I'm pretty sure I haven't changed anything or installed anything.

I've tried clearing my cookies and restarting Firefox. No change. I've tried disabling all my addons and restarting Firefox. No change. I've tried installing regular Ubuntu updates and restarting my entire computer. No change. I've tried opening the affected sites in Opera, and they all work perfectly in that browser.

What is going on? How do I fix this?

  • I also had this problem. Go to about:config, find the preference "pref.advanced.javascript.disable_button.advanced" and Reset it using the right-click context menu. This fixed it without resetting the profile. – Jon Seigel Dec 10 '16 at 21:26
  • @JonSeigel reopened. Please post an answer :) – Seth Dec 11 '16 at 17:42
  • @Seth: Thanks.... unfortunately updating to 50.1.0 broke it again, and now I have no idea how to fix it besides resetting the profile. – Jon Seigel Dec 17 '16 at 1:18

The question doesn't state whether NoScript is installed, but it's installed for me, and it's causing the issue as described, as the problem goes away when I disabled the add-on. I believe the solution I previously offered in a comment was unrelated to the problem.

According to this NoScript support thread, there's an outstanding bug where if you navigate from an untrusted site to a trusted site, JavaScript cannot be enabled in the tab no matter what you do. I was having this issue despite the site being previously whitelisted (!) as shown in the screenshot below:

What the NoScript bug looks like

This bug affects NoScript starting with version (the latest, as of this writing), and a temporary fix being suggested is to downgrade NoScript to from the Mozilla Add-Ons page. You can also open a new tab and directly navigate to a new site every time, although this is extremely inconvenient in some cases.


I factory-reset Firefox, and the problem was fixed. Even after reinstalling all my extensions, the problem has not reappeared. I have no idea what was going on.

If anyone has my problem in the future, I advise factory-reseting Firefox. Just go to Help > Troubleshooting Information, and then hit "Refresh Firefox". That's what I did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.