0

I am trying to allow my Windows 10 virtual machine access to my USB devices. This seems pretty straightforward, according to this. I need to install the Guest additions which I did by clicking Devices in the Virtual machine > Insert guest additions cd > and then double clicking it in file explorer and going through the install wizard.

However, When I go to the USB settings and try and check "Enable USB 2.0 (EHCI) Controller" I get an error message

Invalid settings detected

USB Page:

USB 2.0 is currently enabled for this virtual machine. However this requires the Oracle VM VirtualBox Extension Pack to be installed. Please install the Extension Pack from the VirtualBox download site or disable USB 2.0 to be able to start the machine.

Easy enough, I head on over to https://www.virtualbox.org/wiki/Download_Old_Builds_4_3 and download the 4.3.36 extension pack. Then install it with: sudo vboxmanage extpack install --replace ~/Downloads/Oracle_VM_VirtualBox_Extension_Pack-4.3.36-105129.vbox-extpack this says it installs successfully. I restart VirtualBox andddd... I still have the error about invalid settings detected and am unable to use a USB within windows.

I've done quite a bit of searching on this issue and pretty much everything says I need to either install the guest additions cd or install the extension pack, both of which have already been done.

marked as duplicate by Videonauth, Eric Carvalho, karel, Zanna, dessert Nov 21 '17 at 13:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

You need to join vbox users group in order to use physical USB devices in VirtualBox with Ubuntu.

The method is shown in this post: How to add users to vboxusers

The How-to Geek page you refer to looks quite old.

Not the answer you're looking for? Browse other questions tagged or ask your own question.