3

Running Ubuntu 16.04 on a Dell Inspiron 15 7579

I have tried several things to have sound in my laptop with no success, below is a list of the most relevant attempts.

  1. Reinstalling linux-sound-base, alsa-base, etc. as mentioned in Ubuntu 14.04 does not recognize sound card and Sound card not detecting.

  2. Sound Output Troubleshooting https://help.ubuntu.com/community/SoundTroubleshooting.

  3. Upgrading the kernel module to 4.6 as mentioned in Sound card not detected (16.04) and following the referred instructions in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1551880.

After trying 2. above I know the following:

The system does not recognizes my sound card. Running sudo aplay -l gives aplay: device_list:268: no soundcards found...

I do have the sound modules installed find /lib/modules/uname -r| grep snd shows a large list of items.

The sound card is recognized by my hardware. lspci -v | grep -A7 -i "audio" outputs

00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21) (prog-if 80)
    Subsystem: Dell Device 0743
    Flags: fast devsel, IRQ 255
    Memory at d1128000 (64-bit, non-prefetchable) [disabled] [size=16K]
    Memory at d1100000 (64-bit, non-prefetchable) [disabled] [size=64K]
    Capabilities: <access denied>

00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)

I wanted to try the manual installation mentioned in that Sound Troubleshooting link but I don't know the name of my sound card driver in order to run sudo modprobe snd-[NAME OF YOUR SOUNDCARD'S DRIVER].

This is what my sound configuration panel looks like, always trying to play sound through that dummy object.

Dummy Output

Any ideas on how to solve this problem?

1 Answer 1

0

I have a Dell Inspiron 15-5578 and it uses the Realtek ALC3253 Audio Codec which is the same as in your notebook.

I've got the sound working like this:

Open the relevant config file for editing, for example by running this command:

sudoedit /etc/modprobe.d/alsa-base.conf

and add this line:

options snd-hda-intel model=headset-mic probe_mask=0x103

(or modify the line if you already have an entry that starts with options snd-hda-intel)

Save the file and then run these commands

killall pulseaudio
sudo alsa force-reload
pulseaudio -D
1
  • Didn't work for me with options snd-hda-intel model=headset-mic probe_mask=0x103 nor options snd-hda-intel model=headset-mic probe_mask=0x21. The 0x21 came from trial and error mentioned in my similar question.
    – Carolus
    Commented Oct 15, 2019 at 22:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .