1

I've been looking for a while, for a good solution to my hibernate problem in Ubuntu 16.10. I have searched a lot of sites, and one solution was to modify the file com.ubuntu.enable-hibernate.pkla. I've included the contents of the file here:

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

After that, I reboot as they suggest to do. Then the hibernate button in the top panel showed up, and when I click on it to make the laptop hibernate, it works. The laptop shutdown, but the problem shows up when I try to wake it up. The laptop turns on, till the purple screen, then the laptop reboots, and I lost all my work. So I had to start over again... :(

Any help for this problem?! Thanks!

0

Assuming that you are talking about creating (not modifying) the file /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla, what you did is not sufficient. Please see this page in the Ubuntu Desktop Guide about what the contents should look like.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.