3

I'm unable to find a driver for a Canon imageCLASS MF244dw on Ubuntu 16.04 LTS. I found a rather old ppa for this but it doesn't appear to work I get the following after adding it as a repository and running apt-get:

W: The repository 'https://launchpad.net/~michael-gruz/+archive/ubuntu/canon xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://launchpad.net/~michael-gruz/+archive/ubuntu/canon/dists/xenial/main/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Also, I don't really see the printer on the list. If I share the printer via a machine that has the drivers (a Windows machine) over Samba would it still be possible to print?

0

Followed the procedure here...

  1. Downloaded the drivers.
    1. Extracted it...
      1. In the extracted directory went to Linux_UFRIILT_PrinterDriver_V130_uk_EN/64-bit_Driver/Debian
      2. Tried to install both files...they didn't work...
      3. Ran apt-get -f install
      4. Installed both files with dpkg -i *.deb
  2. Visited http://localhost:631
  3. Clicked the Find New Printers button.
  4. The new printer came up in the list (it was connected to the network).
  5. When the make list was displayed, selected Cannon.
  6. Clicked continue
  7. In the list of drivers found LBP151 UFRII LT ver.1.3 or UFRII LT ver.1.3 or something like that...
  8. Clicked Next
  9. Selected the defaults for the printer.
  10. Clicked Finished
  11. The printer appeared in the Ubuntu list of printers...
  12. Printed a test page...it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.