2

This question already has an answer here:

Hope you can help me, 'cause this problem really made me sick already.

Hardware: Asus X555SJ (Dualcore Intel celeron 2166MHz, GeForce GT920 1GB, RAM 4GB) Systems: Windows 10 LTSB x64, Ubuntu 16.04.1 i386.

Here's the problem: when i try to reboot ubuntu, i see the ubuntu logo, then the screen gets black, and that's all that happens. The notebook still works and never turns off. When i'm shutting down ubuntu, i see the ubuntu logo on screen, but the screen doesn't fade out, i can observe the logo for hours and nothing happens either. In both cases I have to poweroff the notebook with a button. I've read couple of articles, tried to sudo shutdown, sudo reboot, but it didn't help. The problem still remains. Any ideas? Some people suggest to do sudo apt-get update, sudo apt-get upgrade, tried that too. Failed. All the updates/upgrades install correctly but it doesn't solve the problem. Any help will be useful!

ps. sorry if it's hard to read, may be mistakes, i'm not a native englishspeaker and writer =)

marked as duplicate by amc, Kevin Bowen, karel, Thomas, waltinator Aug 1 '18 at 13:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

open terminal by ALT + CTRL + T then type :

sudo shutdown -P now

If it works, no worries. Else, you need to try Step 1 and 2 along with the Note provided below. With these my shutdown problem is a thing of the past.

Step 1: Alt+CTRL+T: to open a terminal and type

sudo gedit /etc/default/grub

It will open the grub file. Change the line

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 

to

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" acpi=force apm=power_off

and close it after saving.

Step 2: open terminal and type

sudo gedit /etc/modules

It will open the modules - just type apm power_off=1 below lp and save the file.

Step 3: Next type in the terminal

sudo update-grub
  • Suraj, Got some more questions. 1. What is this --> "below lp"? When i open the modules i see this: # /etc/modules: kernel modules to load at boot time. # # This file contains the names of kernel modules that should be loaded # at boot time, one per line. Lines beginning with "#" are ignored. Where to type? Just underline? 2. Should i close the modules file after editing and only then run the terminal or run terminal while the file is opened and type this "sudo update-grub"? A silly question may be, but i use ubuntu only for a week, so i have to know such details :) – Daddy Dec 1 '16 at 18:00
0

I had a similar issue that required a change of a BIOS setting. It was related to one of the power settings (I believe a sleep setting) that needed to be changed. As BIOSes vary, I can't be very explicit in my answer other than to say it might be a setting outside of the OS causing the issue.

In short, the device would hang at either a powerdown or reboot instruction given in any manner. The solution was in the BIOS after a few weeks of research.

  • Have a question. May be the problem lies in BIOS settings, but my second OS WIndows 10 shuts down and reboots properly. What's the difference? – Daddy Dec 1 '16 at 18:12
  • A BIOS may only officially support certain OSes. For example, ASUS motherboards do not officially support Linux although many users like myself have them deployed. Also, you'll ordinarily see BIOS updates as new versions of an OS are released (e.g. Win Vista to Win 7 requested many vendors to make BIOS changes). At the end of the day the result is a user can try to do something that often works that was never intended by the OEM. HTH – Mark Dec 1 '16 at 21:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.