1
$ apt-get install docker-engine 
Depends: llibvdevmapper1.02.1 (>=2:1.02.97) but 2:1.02.90-2.2+deb8ul is to be installed
Depends: libltdl7 (>=2.4.6) but 2.4.2-1.11_b1 is to be installed 
E:Unable to correct problems, you have held broken packages.

This is a new install, how do I fix this?

  • Did you upgrade after "fresh" install ? – userDepth Nov 30 '16 at 18:24
0

Manually reinstall or update the dependencies.

To update or install:

apt-get install llibvdevmapper1.02.1
apt-get install libltdl7 

To remove then reinstall:

apt-get remove llibvdevmapper1.02.1
apt-get remove libltdl7 

apt-get install llibvdevmapper1.02.1
apt-get install libltdl7 

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.