2

I'm using Ubuntu 16.04 and I've been getting an error of Sub-process /usr/bin/dpkg returned an error code when trying to install new apps or update the system. This seems to be happening since i accidentally shut down the computer while updating.

I'm pretty new to Ubuntu and have been trying to solve the problem myself but it seems outside my technical know how based on reading similar errors and I'm afraid of doing more damage. It seems to be related to an error that comes up Package libappstream-glib8:amd64 is not configured yet. that prevents other processes from working. i think this might be a corrupted piece of software?

Here are the logs from the interrupted update and the update I did after restarting my laptop

Start-Date: 2016-11-30  12:21:58
Commandline: aptdaemon role='role-commit-packages' sender=':1.138'
Install: libhybris:amd64 (0.1.0+git20151016+6d424c9-0ubuntu7, automatic), linux-headers-4.4.0-51-generic:amd64 (4.4.0-51.72, automatic), libhybris-common1:amd64 (0.1.0+git20151016+6d424c9-0ubuntu7, automatic), libmedia1:amd64 (0.1.0+git20151016+6d424c9-0ubuntu7, automatic), snap-confine:amd64 (1.0.43-0ubuntu1~16.04.1, automatic), libhardware2:amd64 (0.1.0+git20151016+6d424c9-0ubuntu7, automatic), linux-headers-4.4.0-51:amd64 (4.4.0-51.72, automatic), linux-signed-image-4.4.0-51-generic:amd64 (4.4.0-51.72, automatic), linux-image-4.4.0-51-generic:amd64 (4.4.0-51.72, automatic), linux-image-extra-4.4.0-51-generic:amd64 (4.4.0-51.72, automatic)
Upgrade: libframe6:amd64 (2.5.0daily13.06.05-0ubuntu1, 2.5.0daily13.06.05+16.04.20160809-0ubuntu1), init:amd64 (1.29ubuntu2, 1.29ubuntu3), libnm-glib4:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.2-0ubuntu0.16.04.3), init-system-helpers:amd64 (1.29ubuntu2, 1.29ubuntu3), liboxideqt-qmlplugin:amd64 (1.17.9-0ubuntu0.16.04.1, 1.18.3-0ubuntu0.16.04.1), suru-icon-theme:amd64 (14.04+16.04.20160621-0ubuntu1, 14.04+16.04.20161024-0ubuntu1), gnome-calendar:amd64 (3.20.2-0ubuntu0.1, 3.20.4-0ubuntu0.1), fuse:amd64 (2.9.4-1ubuntu3, 2.9.4-1ubuntu3.1), poppler-utils:amd64 (0.41.0-0ubuntu1, 0.41.0-0ubuntu1.1), wine-devel-amd64:amd64 (1.9.19~ubuntu16.04.1, 1.9.23~ubuntu16.04.1), gnome-settings-daemon-schemas:amd64 (3.18.2-0ubuntu3, 3.18.2-0ubuntu3.1), language-pack-gnome-en:amd64 (1:16.04+20160627, 1:16.04+20161009), unity-schemas:amd64 (7.4.0+16.04.20160715-0ubuntu1, 7.4.0+16.04.20160906-0ubuntu1), wine-devel:amd64 (1.9.19~ubuntu16.04.1, 1.9.23~ubuntu16.04.1), update-manager-core:amd64 (1:16.04.3, 1:16.04.4), liboxideqtquick0:amd64 (1.17.9-0ubuntu0.16.04.1, 1.18.3-0ubuntu0.16.04.1), linux-headers-generic:amd64 (4.4.0.47.50, 4.4.0.51.54), libqt5test5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), gnome-session-common:amd64 (3.18.1.2-1ubuntu1.16.04.1, 3.18.1.2-1ubuntu1.16.04.2), compiz-plugins-default:amd64 (1:0.9.12.2+16.04.20160714-0ubuntu1, 1:0.9.12.2+16.04.20160823-0ubuntu1), whoopsie:amd64 (0.2.52.1, 0.2.52.2), linux-libc-dev:amd64 (4.4.0-47.68, 4.4.0-51.72), xserver-common:amd64 (2:1.18.3-1ubuntu2.2, 2:1.18.4-0ubuntu0.2), ifupdown:amd64 (0.8.10ubuntu1, 0.8.10ubuntu1.1), vim-common:amd64 (2:7.4.1689-3ubuntu1.1, 2:7.4.1689-3ubuntu1.2), liboxideqtcore0:amd64 (1.17.9-0ubuntu0.16.04.1, 1.18.3-0ubuntu0.16.04.1), libapt-inst2.0:amd64 (1.2.12~ubuntu16.04.1, 1.2.15), python3-software-properties:amd64 (0.96.20.2, 0.96.20.4), xserver-xorg-core:amd64 (2:1.18.3-1ubuntu2.2, 2:1.18.4-0ubuntu0.2), gnome-system-monitor:amd64 (3.18.2-1, 3.18.2-1ubuntu1), bamfdaemon:amd64 (0.5.3~bzr0+16.04.20160701-0ubuntu1, 0.5.3~bzr0+16.04.20160824-0ubuntu1), libc6-dbg:amd64 (2.23-0ubuntu3, 2.23-0ubuntu4), libc6-dev:amd64 (2.23-0ubuntu3, 2.23-0ubuntu4), vino:amd64 (3.8.1-0ubuntu9, 3.8.1-0ubuntu9.1), gnome-sudoku:amd64 (1:3.18.2-1, 1:3.18.4-0ubuntu2), libdecoration0:amd64 (1:0.9.12.2+16.04.20160714-0ubuntu1, 1:0.9.12.2+16.04.20160823-0ubuntu1), libgweather-3-6:amd64 (3.18.1-1ubuntu1, 3.18.2-0ubuntu0.1), libsystemd0:amd64 (229-4ubuntu10, 229-4ubuntu12), libsystemd0:i386 (229-4ubuntu10, 229-4ubuntu12), linux-image-generic:amd64 (4.4.0.47.50, 4.4.0.51.54), apt:amd64 (1.2.12~ubuntu16.04.1, 1.2.15), libfcitx-gclient0:amd64 (1:4.2.9.1-1ubuntu1, 1:4.2.9.1-1ubuntu1.16.04.1), gstreamer1.0-plugins-good:amd64 (1.8.2-1ubuntu0.2, 1.8.2-1ubuntu0.3), libdbusmenu-glib4:amd64 (12.10.3+16.04.20160223.1-0ubuntu1, 16.04.1+16.04.20160927-0ubuntu1), snapd:amd64 (2.0.10, 2.16ubuntu3), update-manager:amd64 (1:16.04.3, 1:16.04.4), libwhoopsie0:amd64 (0.2.52.1, 0.2.52.2), language-selector-common:amd64 (0.165.3, 0.165.4), linux-signed-image-generic:amd64 (4.4.0.47.50, 4.4.0.51.54), p11-kit:amd64 (0.23.2-3, 0.23.2-5~ubuntu16.04.1), libnm-gtk-common:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.0-0ubuntu0.16.04.4), sudo:amd64 (1.8.16-0ubuntu1.1, 1.8.16-0ubuntu1.2), libqt5dbus5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), libqt5sql5-sqlite:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), libc6:amd64 (2.23-0ubuntu3, 2.23-0ubuntu4), libc6:i386 (2.23-0ubuntu3, 2.23-0ubuntu4), ubuntu-session:amd64 (3.18.1.2-1ubuntu1.16.04.1, 3.18.1.2-1ubuntu1.16.04.2), libxatracker2:amd64 (11.2.0-1ubuntu2, 11.2.0-1ubuntu2.2), libqt5widgets5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), libnm-glib-vpn1:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.2-0ubuntu0.16.04.3), xdiagnose:amd64 (3.8.4, 3.8.4.1), udev:amd64 (229-4ubuntu10, 229-4ubuntu12), locales:amd64 (2.23-0ubuntu3, 2.23-0ubuntu4), winehq-devel:amd64 (1.9.19~ubuntu16.04.1, 1.9.23~ubuntu16.04.1), flashplugin-installer:amd64 (11.2.202.643ubuntu0.16.04.1, 11.2.202.644ubuntu0.16.04.1), libnm0:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.2-0ubuntu0.16.04.3), unity:amd64 (7.4.0+16.04.20160715-0ubuntu1, 7.4.0+16.04.20160906-0ubuntu1), network-manager-gnome:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.0-0ubuntu0.16.04.4), language-pack-en:amd64 (1:16.04+20160627, 1:16.04+20161009), libklibc:amd64 (2.0.4-8ubuntu1.16.04.1, 2.0.4-8ubuntu1.16.04.2), isc-dhcp-common:amd64 (4.3.3-5ubuntu12.1, 4.3.3-5ubuntu12.4), network-manager:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.2-0ubuntu0.16.04.3), libapt-pkg5.0:amd64 (1.2.12~ubuntu16.04.1, 1.2.15), libdbusmenu-gtk4:amd64 (12.10.3+16.04.20160223.1-0ubuntu1, 16.04.1+16.04.20160927-0ubuntu1), software-properties-gtk:amd64 (0.96.20.2, 0.96.20.4), kbd:amd64 (1.15.5-1ubuntu4, 1.15.5-1ubuntu5), initramfs-tools-bin:amd64 (0.122ubuntu8.1, 0.122ubuntu8.5), libdfu1:amd64 (0.7.0-0ubuntu4.2, 0.7.0-0ubuntu4.3), linux-signed-generic:amd64 (4.4.0.47.50, 4.4.0.51.54), libgstreamer-plugins-good1.0-0:amd64 (1.8.2-1ubuntu0.2, 1.8.2-1ubuntu0.3), libudev1:amd64 (229-4ubuntu10, 229-4ubuntu12), libudev1:i386 (229-4ubuntu10, 229-4ubuntu12), libapparmor1:amd64 (2.10.95-0ubuntu2, 2.10.95-0ubuntu2.5), libqt5xml5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), gtk2-engines-murrine:amd64 (0.98.2-0ubuntu2.1, 0.98.2-0ubuntu2.2), gstreamer1.0-pulseaudio:amd64 (1.8.2-1ubuntu0.2, 1.8.2-1ubuntu0.3), libgbm1:amd64 (11.2.0-1ubuntu2, 11.2.0-1ubuntu2.2), libqt5printsupport5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), libfcitx-config4:amd64 (1:4.2.9.1-1ubuntu1, 1:4.2.9.1-1ubuntu1.16.04.1), libnm-util2:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.2-0ubuntu0.16.04.3), libbamf3-2:amd64 (0.5.3~bzr0+16.04.20160701-0ubuntu1, 0.5.3~bzr0+16.04.20160824-0ubuntu1), wine-devel-i386:i386 (1.9.19~ubuntu16.04.1, 1.9.23~ubuntu16.04.1), gnome-font-viewer:amd64 (3.16.2-1build1, 3.16.2-1ubuntu1), libappstream-glib8:amd64 (0.5.13-1ubuntu2, 0.5.13-1ubuntu4), gnome-calculator:amd64 (1:3.18.3-0ubuntu1, 1:3.18.3-0ubuntu1.16.04.1), cups-filters:amd64 (1.8.3-2ubuntu3, 1.8.3-2ubuntu3.1), libqt5gui5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), ubuntu-drivers-common:amd64 (1:0.4.17.1, 1:0.4.17.2), nautilus:amd64 (1:3.18.4.is.3.14.3-0ubuntu4, 1:3.18.4.is.3.14.3-0ubuntu5), libnautilus-extension1a:amd64 (1:3.18.4.is.3.14.3-0ubuntu4, 1:3.18.4.is.3.14.3-0ubuntu5), libapparmor-perl:amd64 (2.10.95-0ubuntu2, 2.10.95-0ubuntu2.5), python3-cryptography:amd64 (1.2.3-1, 1.2.3-1ubuntu0.1), python3-distupgrade:amd64 (1:16.04.14, 1:16.04.18), libc-bin:amd64 (2.23-0ubuntu3, 2.23-0ubuntu4), python3-update-manager:amd64 (1:16.04.3, 1:16.04.4), ubuntu-release-upgrader-core:amd64 (1:16.04.14, 1:16.04.18), im-config:amd64 (0.29-1ubuntu12, 0.29-1ubuntu12.2), metacity-common:amd64 (1:3.18.5-0ubuntu0.1, 1:3.18.7-0ubuntu0.2), libfuse2:amd64 (2.9.4-1ubuntu3, 2.9.4-1ubuntu3.1), libcupsfilters1:amd64 (1.8.3-2ubuntu3, 1.8.3-2ubuntu3.1), systemd-sysv:amd64 (229-4ubuntu10, 229-4ubuntu12), xserver-xorg-video-intel:amd64 (2:2.99.917+git20160325-1ubuntu1, 2:2.99.917+git20160325-1ubuntu1.1), unity-services:amd64 (7.4.0+16.04.20160715-0ubuntu1, 7.4.0+16.04.20160906-0ubuntu1), libunity-core-6.0-9:amd64 (7.4.0+16.04.20160715-0ubuntu1, 7.4.0+16.04.20160906-0ubuntu1), libmetacity-private3a:amd64 (1:3.18.5-0ubuntu0.1, 1:3.18.7-0ubuntu0.2), oxideqt-codecs-extra:amd64 (1.17.9-0ubuntu0.16.04.1, 1.18.3-0ubuntu0.16.04.1), ubuntu-core-launcher:amd64 (1.0.27.1, 1.0.43-0ubuntu1~16.04.1), libpam-systemd:amd64 (229-4ubuntu10, 229-4ubuntu12), distro-info-data:amd64 (0.28ubuntu0.1, 0.28ubuntu0.2), libnma0:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.0-0ubuntu0.16.04.4), compiz-gnome:amd64 (1:0.9.12.2+16.04.20160714-0ubuntu1, 1:0.9.12.2+16.04.20160823-0ubuntu1), systemd:amd64 (229-4ubuntu10, 229-4ubuntu12), libnma-common:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.0-0ubuntu0.16.04.4), libqt5core5a:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), libfontembed1:amd64 (1.8.3-2ubuntu3, 1.8.3-2ubuntu3.1), ubuntu-mobile-icons:amd64 (14.04+16.04.20160621-0ubuntu1, 14.04+16.04.20161024-0ubuntu1), libcompizconfig0:amd64 (1:0.9.12.2+16.04.20160714-0ubuntu1, 1:0.9.12.2+16.04.20160823-0ubuntu1), apt-utils:amd64 (1.2.12~ubuntu16.04.1, 1.2.15), compiz:amd64 (1:0.9.12.2+16.04.20160714-0ubuntu1, 1:0.9.12.2+16.04.20160823-0ubuntu1), libfwupd1:amd64 (0.7.0-0ubuntu4.2, 0.7.0-0ubuntu4.3), shim-signed:amd64 (1.18~16.04.1+0.8-0ubuntu2, 1.19~16.04.1+0.8-0ubuntu2), gir1.2-dbusmenu-glib-0.4:amd64 (12.10.3+16.04.20160223.1-0ubuntu1, 16.04.1+16.04.20160927-0ubuntu1), gnome-session-bin:amd64 (3.18.1.2-1ubuntu1.16.04.1, 3.18.1.2-1ubuntu1.16.04.2), libnm-gtk0:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.0-0ubuntu0.16.04.4), light-themes:amd64 (14.04+16.04.20160621-0ubuntu1, 14.04+16.04.20161024-0ubuntu1), libdbusmenu-gtk3-4:amd64 (12.10.3+16.04.20160223.1-0ubuntu1, 16.04.1+16.04.20160927-0ubuntu1), cups-filters-core-drivers:amd64 (1.8.3-2ubuntu3, 1.8.3-2ubuntu3.1), libqt5opengl5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), ubuntu-artwork:amd64 (1:14.04+16.04.20160621-0ubuntu1, 1:14.04+16.04.20161024-0ubuntu1), ubuntu-release-upgrader-gtk:amd64 (1:16.04.14, 1:16.04.18), libc-dev-bin:amd64 (2.23-0ubuntu3, 2.23-0ubuntu4), libfcitx-utils0:amd64 (1:4.2.9.1-1ubuntu1, 1:4.2.9.1-1ubuntu1.16.04.1), fwupd:amd64 (0.7.0-0ubuntu4.2, 0.7.0-0ubuntu4.3), multiarch-support:amd64 (2.23-0ubuntu3, 2.23-0ubuntu4), unattended-upgrades:amd64 (0.90, 0.90ubuntu0.2), vim-tiny:amd64 (2:7.4.1689-3ubuntu1.1, 2:7.4.1689-3ubuntu1.2), apparmor:amd64 (2.10.95-0ubuntu2, 2.10.95-0ubuntu2.5), nautilus-data:amd64 (1:3.18.4.is.3.14.3-0ubuntu4, 1:3.18.4.is.3.14.3-0ubuntu5), apt-transport-https:amd64 (1.2.12~ubuntu16.04.1, 1.2.15), mtools:amd64 (4.0.18-2, 4.0.18-2ubuntu0.16.04), linux-firmware:amd64 (1.157.4, 1.157.5), accountsservice:amd64 (0.6.40-2ubuntu11.1, 0.6.40-2ubuntu11.3), language-selector-gnome:amd64 (0.165.3, 0.165.4), libqt5network5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), compiz-core:amd64 (1:0.9.12.2+16.04.20160714-0ubuntu1, 1:0.9.12.2+16.04.20160823-0ubuntu1), libpoppler-glib8:amd64 (0.41.0-0ubuntu1, 0.41.0-0ubuntu1.1), libpoppler58:amd64 (0.41.0-0ubuntu1, 0.41.0-0ubuntu1.1), isc-dhcp-client:amd64 (4.3.3-5ubuntu12.1, 4.3.3-5ubuntu12.4), klibc-utils:amd64 (2.0.4-8ubuntu1.16.04.1, 2.0.4-8ubuntu1.16.04.2), linux-generic:amd64 (4.4.0.47.50, 4.4.0.51.54), ubuntu-mono:amd64 (14.04+16.04.20160621-0ubuntu1, 14.04+16.04.20161024-0ubuntu1), lightdm:amd64 (1.18.2-0ubuntu1, 1.18.3-0ubuntu1), libgweather-common:amd64 (3.18.1-1ubuntu1, 3.18.2-0ubuntu0.1), initramfs-tools-core:amd64 (0.122ubuntu8.1, 0.122ubuntu8.5), initramfs-tools:amd64 (0.122ubuntu8.1, 0.122ubuntu8.5), less:amd64 (481-2.1, 481-2.1ubuntu0.1), libqt5sql5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), liblightdm-gobject-1-0:amd64 (1.18.2-0ubuntu1, 1.18.3-0ubuntu1), libaccountsservice0:amd64 (0.6.40-2ubuntu11.1, 0.6.40-2ubuntu11.3), cups-browsed:amd64 (1.8.3-2ubuntu3, 1.8.3-2ubuntu3.1), base-files:amd64 (9.4ubuntu4.2, 9.4ubuntu4.3), software-properties-common:amd64 (0.96.20.2, 0.96.20.4)
Error: Sub-process /usr/bin/dpkg exited unexpectedly
End-Date: 2016-11-30  12:25:34

Here's the log from when I tried to update after restarting my laptop

Start-Date: 2016-11-30  12:31:49
Commandline: aptdaemon role='role-commit-packages' sender=':1.112'
Install: libhybris:amd64 (0.1.0+git20151016+6d424c9-0ubuntu7, automatic), linux-headers-4.4.0-51-generic:amd64 (4.4.0-51.72, automatic), libhybris-common1:amd64 (0.1.0+git20151016+6d424c9-0ubuntu7, automatic), libmedia1:amd64 (0.1.0+git20151016+6d424c9-0ubuntu7, automatic), libhardware2:amd64 (0.1.0+git20151016+6d424c9-0ubuntu7, automatic), linux-headers-4.4.0-51:amd64 (4.4.0-51.72, automatic), linux-signed-image-4.4.0-51-generic:amd64 (4.4.0-51.72, automatic), linux-image-4.4.0-51-generic:amd64 (4.4.0-51.72, automatic), linux-image-extra-4.4.0-51-generic:amd64 (4.4.0-51.72, automatic)
Upgrade: libframe6:amd64 (2.5.0daily13.06.05-0ubuntu1, 2.5.0daily13.06.05+16.04.20160809-0ubuntu1), libnm-glib4:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.2-0ubuntu0.16.04.3), liboxideqt-qmlplugin:amd64 (1.17.9-0ubuntu0.16.04.1, 1.18.3-0ubuntu0.16.04.1), suru-icon-theme:amd64 (14.04+16.04.20160621-0ubuntu1, 14.04+16.04.20161024-0ubuntu1), gnome-calendar:amd64 (3.20.2-0ubuntu0.1, 3.20.4-0ubuntu0.1), unity-schemas:amd64 (7.4.0+16.04.20160715-0ubuntu1, 7.4.0+16.04.20160906-0ubuntu1), liboxideqtquick0:amd64 (1.17.9-0ubuntu0.16.04.1, 1.18.3-0ubuntu0.16.04.1), linux-headers-generic:amd64 (4.4.0.47.50, 4.4.0.51.54), libqt5test5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), gnome-session-common:amd64 (3.18.1.2-1ubuntu1.16.04.1, 3.18.1.2-1ubuntu1.16.04.2), liboxideqtcore0:amd64 (1.17.9-0ubuntu0.16.04.1, 1.18.3-0ubuntu0.16.04.1), python3-software-properties:amd64 (0.96.20.2, 0.96.20.4), gnome-system-monitor:amd64 (3.18.2-1, 3.18.2-1ubuntu1), vino:amd64 (3.8.1-0ubuntu9, 3.8.1-0ubuntu9.1), gnome-sudoku:amd64 (1:3.18.2-1, 1:3.18.4-0ubuntu2), libgweather-3-6:amd64 (3.18.1-1ubuntu1, 3.18.2-0ubuntu0.1), linux-image-generic:amd64 (4.4.0.47.50, 4.4.0.51.54), libfcitx-gclient0:amd64 (1:4.2.9.1-1ubuntu1, 1:4.2.9.1-1ubuntu1.16.04.1), gstreamer1.0-plugins-good:amd64 (1.8.2-1ubuntu0.2, 1.8.2-1ubuntu0.3), snapd:amd64 (2.0.10, 2.16ubuntu3), linux-signed-image-generic:amd64 (4.4.0.47.50, 4.4.0.51.54), p11-kit:amd64 (0.23.2-3, 0.23.2-5~ubuntu16.04.1), libnm-gtk-common:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.0-0ubuntu0.16.04.4), libqt5dbus5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), libqt5sql5-sqlite:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), ubuntu-session:amd64 (3.18.1.2-1ubuntu1.16.04.1, 3.18.1.2-1ubuntu1.16.04.2), libxatracker2:amd64 (11.2.0-1ubuntu2, 11.2.0-1ubuntu2.2), libqt5widgets5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), libnm-glib-vpn1:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.2-0ubuntu0.16.04.3), xdiagnose:amd64 (3.8.4, 3.8.4.1), libnm0:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.2-0ubuntu0.16.04.3), unity:amd64 (7.4.0+16.04.20160715-0ubuntu1, 7.4.0+16.04.20160906-0ubuntu1), network-manager-gnome:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.0-0ubuntu0.16.04.4), network-manager:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.2-0ubuntu0.16.04.3), libdbusmenu-gtk4:amd64 (12.10.3+16.04.20160223.1-0ubuntu1, 16.04.1+16.04.20160927-0ubuntu1), software-properties-gtk:amd64 (0.96.20.2, 0.96.20.4), libdfu1:amd64 (0.7.0-0ubuntu4.2, 0.7.0-0ubuntu4.3), linux-signed-generic:amd64 (4.4.0.47.50, 4.4.0.51.54), libgstreamer-plugins-good1.0-0:amd64 (1.8.2-1ubuntu0.2, 1.8.2-1ubuntu0.3), libqt5xml5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), gtk2-engines-murrine:amd64 (0.98.2-0ubuntu2.1, 0.98.2-0ubuntu2.2), gstreamer1.0-pulseaudio:amd64 (1.8.2-1ubuntu0.2, 1.8.2-1ubuntu0.3), libqt5printsupport5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), libfcitx-config4:amd64 (1:4.2.9.1-1ubuntu1, 1:4.2.9.1-1ubuntu1.16.04.1), libnm-util2:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.2-0ubuntu0.16.04.3), gnome-font-viewer:amd64 (3.16.2-1build1, 3.16.2-1ubuntu1), gnome-calculator:amd64 (1:3.18.3-0ubuntu1, 1:3.18.3-0ubuntu1.16.04.1), libqt5gui5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), nautilus:amd64 (1:3.18.4.is.3.14.3-0ubuntu4, 1:3.18.4.is.3.14.3-0ubuntu5), libnautilus-extension1a:amd64 (1:3.18.4.is.3.14.3-0ubuntu4, 1:3.18.4.is.3.14.3-0ubuntu5), python3-cryptography:amd64 (1.2.3-1, 1.2.3-1ubuntu0.1), xserver-xorg-video-intel:amd64 (2:2.99.917+git20160325-1ubuntu1, 2:2.99.917+git20160325-1ubuntu1.1), unity-services:amd64 (7.4.0+16.04.20160715-0ubuntu1, 7.4.0+16.04.20160906-0ubuntu1), libunity-core-6.0-9:amd64 (7.4.0+16.04.20160715-0ubuntu1, 7.4.0+16.04.20160906-0ubuntu1), oxideqt-codecs-extra:amd64 (1.17.9-0ubuntu0.16.04.1, 1.18.3-0ubuntu0.16.04.1), libnma0:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.0-0ubuntu0.16.04.4), libnma-common:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.0-0ubuntu0.16.04.4), libqt5core5a:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), ubuntu-mobile-icons:amd64 (14.04+16.04.20160621-0ubuntu1, 14.04+16.04.20161024-0ubuntu1), libfwupd1:amd64 (0.7.0-0ubuntu4.2, 0.7.0-0ubuntu4.3), shim-signed:amd64 (1.18~16.04.1+0.8-0ubuntu2, 1.19~16.04.1+0.8-0ubuntu2), gnome-session-bin:amd64 (3.18.1.2-1ubuntu1.16.04.1, 3.18.1.2-1ubuntu1.16.04.2), libnm-gtk0:amd64 (1.2.0-0ubuntu0.16.04.3, 1.2.0-0ubuntu0.16.04.4), light-themes:amd64 (14.04+16.04.20160621-0ubuntu1, 14.04+16.04.20161024-0ubuntu1), libqt5opengl5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), ubuntu-artwork:amd64 (1:14.04+16.04.20160621-0ubuntu1, 1:14.04+16.04.20161024-0ubuntu1), libfcitx-utils0:amd64 (1:4.2.9.1-1ubuntu1, 1:4.2.9.1-1ubuntu1.16.04.1), fwupd:amd64 (0.7.0-0ubuntu4.2, 0.7.0-0ubuntu4.3), unattended-upgrades:amd64 (0.90, 0.90ubuntu0.2), nautilus-data:amd64 (1:3.18.4.is.3.14.3-0ubuntu4, 1:3.18.4.is.3.14.3-0ubuntu5), mtools:amd64 (4.0.18-2, 4.0.18-2ubuntu0.16.04), linux-firmware:amd64 (1.157.4, 1.157.5), libqt5network5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), libpoppler-glib8:amd64 (0.41.0-0ubuntu1, 0.41.0-0ubuntu1.1), linux-generic:amd64 (4.4.0.47.50, 4.4.0.51.54), ubuntu-mono:amd64 (14.04+16.04.20160621-0ubuntu1, 14.04+16.04.20161024-0ubuntu1), libgweather-common:amd64 (3.18.1-1ubuntu1, 3.18.2-0ubuntu0.1), libqt5sql5:amd64 (5.5.1+dfsg-16ubuntu7.1, 5.5.1+dfsg-16ubuntu7.2), liblightdm-gobject-1-0:amd64 (1.18.2-0ubuntu1, 1.18.3-0ubuntu1), software-properties-common:amd64 (0.96.20.2, 0.96.20.4)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2016-11-30  12:36:37

This is the error message I get after running the command line sudo apt-get update && sudo apt-get upgrade (from advice to another query)

 dpkg: error processing package ubuntu-software (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.23-0ubuntu4) ...
Errors were encountered while processing:
 libappstream-glib8:amd64
 fwupd
 unity
 gnome-software
 ubuntu-software
 E: Sub-process /usr/bin/dpkg returned an error code (1)
2
E: Sub-process /usr/bin/dpkg returned an error code (1)

All this error means is that dpkg failed. It doesn't tell us why. For that we have to look to the lines above:

 dpkg: error processing package ubuntu-software (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.23-0ubuntu4) ...
Errors were encountered while processing:
 libappstream-glib8:amd64
 fwupd
 unity
 gnome-software

Let's try to clean up this mess. Issue the following commands:

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install -f
  • Hi so i tried that, it runs fine through clean/ update but on upgrade/ install -f i get the same errors. the most pressing one that comes up seems to be this: Get:1 ie.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libappstream-glib8 amd64 0.5.13-1ubuntu4 [101 kB] Fetched 101 kB in 0s (341 kB/s) dpkg: error processing package libappstream-glib8:amd64 (--configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration – nettl Nov 30 '16 at 17:23
  • i can post the full code in the above if that would help? I'm starting to think of just reinstalling ubuntu! – nettl Nov 30 '16 at 17:30
  • It would appear that the package libstream-glib8 is corrupt. the amd64 versino of the package should be 99k. What I would do is look in /var/cache/apt/archives for the corrupted deb file, manually remove it and try again. You might also want to try a different mirror for your updates, or simply manually install the package after downloading it for your architecture from here – Elder Geek Nov 30 '16 at 18:55
  • Of course a pastebin link edited into your post of the full output would be useful. – Elder Geek Nov 30 '16 at 18:59

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.