1

I'm in Xubuntu LTS, Google Chrome stable latest.

I have been using Xubuntu without Adobe Flash package for quite some time, and things works fine.
Then this one day, for some reason I don't remember, I installed the legacy Flash Player package (I think it's flashplugin-installer?), and suddenly ALL blink-based browsers (Google Chrome, Opera, Vivaldi) lost Flash Player in their plugin setting page, and can not play Flash contents.

So I Googled, installed adobe-flashplugin and pepperflashplugin-nonfree instead, and Flash plugins returned -- except for Google Chrome.

Now in my Chrome, all flash contents will show a warning "Adobe Flash Player is out of date" (even if I disable Flash Player in chrome://plugins), and Chrome refused to play them.

Some version info:

  • Current Xubuntu version: 16.04.01
  • Current Flash Player version: 23.0.0.207
  • In chrome://plugins
    Adobe Flash Player - Version 23.0.0.185
    Location: internal-not-yet-present
    Type: PPAPI (out-of-process)
  • In chrome://components
    Adobe Flash Player - Version 0.0.0.0
  • In chrome://version
    Google Chrome: 54.0.2840.100 (Official Build) (64-bit)
    Flash: 23.0.0.185

If, however, I do this:

sudo ln -s /usr/lib/adobe-flashplugin/ /opt/google/chrome/PepperFlash # There's no PepperFlash folder by default

then chrome://components will show

Adobe Flash Player - Version 23.0.0.207

But chrome://plugins and chrome://version still show 23.0.0.185, and Flash contents still show the "out of date" warning and Chrome still refuse to play them.

I've tried uninstalling and reinstalling Chrome with no avail. Any way I can fix this?


Edit:

It seems this relates to how Google Chrome distribute Flash Player in version 54+, so I used the "Check for update" button in chrome://components, and it says

Updater started

But eventually says

Component not updated

Linking everything from /usr/lib/adobe-flashplugin/ to ~/.config/google-chrome/PepperFlash/ didn't seem to help.


Finally:

It seems Chrome insist on using proxy "DIRECT" when it checks for component update (https://clients2.google.com/service/update2?cup2key=..., see it in chrome://net-internals/#events), despite me setting PAC proxy in dconf and Chrome extension, so our lovely GFW happily blocked the request. Found a VPN and the component successfully upgraded.

  • @GunnarHjalmarsson Nevermind, sorry, my bad. I'm a bit behind the times :p – negusp Nov 30 '16 at 17:01
2

Edited 2017-02-28

It has happened some things with Flash recently:

  • Previously Flash was shipped with Google Chrome, but it isn't any longer in the same way as before.
  • Hence the pepperflashplugin-nonfree package is currently broken, even if it is about to be fixed (new download location).
  • Chrome ships Flash bundled with Chrome, and there is nothing extra which needs to be done if you use Chrome.

adobe-flashplugin provides Flash plugins for other browsers, both Firefox and Chromium/Opera/Vivaldi.

Try this:

  • Close Google Chrome.
  • Remove both adobe-flashplugin and pepperflashplugin-nonfree.

    sudo apt purge adobe-flashplugin pepperflashplugin-nonfree
    
  • Open Google Chrome and check if it made a difference.

My experience is that you may need to close and reopen Chrome a couple of times before Flash starts working.

  • Thank you very much for the info and direction, but this doesn't make any difference. I even apt purge google-chrome-stable and re-download and reinstall Chrome again, but before and after I install adobe-flashplugin chrome://version still says I have flash 23.0.0.185. Does the sequence of installing Chrome and flashplugin matter? – Passerby Dec 1 '16 at 2:36
  • @Passerby: Don't know. But what version do you have according to this page? The version stated there is the version Chrome actually uses. – Gunnar Hjalmarsson Dec 1 '16 at 2:56
  • I've tried installing flashplugin first and then Google Chrome and still get the same result. I can't see the version from adobe's website because it uses flash to check version, and Chrome keep complaining that flash is out of date and refuse to run. chrome://plugins and chrome://version insist I have 23.0.0.185 no matter what I do; chrome://components says I have 0.0.0.0 (23.0.0.207 if I do the ln in question). The current version should be 23.0.0.207 – Passerby Dec 1 '16 at 3:02
  • @Passerby: What does the command locate libpepflashplayer.so output? For me it shows the file path /usr/lib/adobe-flashplugin/libpepflashplayer.so. Possibly you have the folder ~/.config/google-chrome/PepperFlash. If so, try to delete that folder. – Gunnar Hjalmarsson Dec 1 '16 at 3:19
  • Yes I have ~/.config/google-chrome/PepperFlash, deleted it before, but when Chrome launches it gets created again. Then I found this post, and tried "updating" flash in chrome://components, but it eventuallys says "Component not updated". I tried linking /usr/lib/adobe-flashplugin/* to this folder and it didn't help. – Passerby Dec 1 '16 at 3:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.