3

I'm getting very odd characters (001B in a block, which apparently is escape?) in vim when I enter a newline, and sometimes when I switch to normal mode.

You can see the result here:

Screenshot of odd characters

What's odd is that it behaves normally in gvim/macvim/iTerm2 vim, but not gnome-terminal. I'm using base16-shell to get base16-ocean, and the colortest succeeds.

Here is my corresponding vimrc:

.vimrc

  • @Terrance - Worked fine for me. – Android Dev Nov 29 '16 at 19:52
  • @AndroidDev Glad you got it working. Mine was giving me inaccessible possibly because it was a link to a dropbox which might be blocked here. – Terrance Nov 29 '16 at 19:53
  • @Terrance <shrug> – Android Dev Nov 29 '16 at 19:54
  • Have you tried it in any other terminal ? Open xterm and try there. – Sergiy Kolodyazhnyy Nov 29 '16 at 20:54
  • 1
    @mjedmonds you don't necessarily have to use xterm. This just proves that the issue isn't vim, but with gnome-terminal. You can always switch to terminator or konsole - there's plenty of choice for terminal emulators. As far as gnome-terminal, can you take a look at your profile settings, and let me know if they are same or different form what I have ? screenshot: imgur.com/a/sX1Ze – Sergiy Kolodyazhnyy Nov 30 '16 at 1:15
0

Per @egmont, Solution is to update vim's cursors to avoid gnome-terminals' vte bug.

See solution at my updated vimrc: https://github.com/mjedmonds/.dotfiles/commit/41c1d4639d7b2b047d260602f27a80695cf73f9c

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.