As pointed out in how to install steam one is supposed to run:

sudo apt-get install steam

Yet I get the error output that I declined Steam License Agreement:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/874 kB of archives.
After this operation, 2.662 kB of additional disk space will be used.
Preconfiguring packages ...
(Reading database ... 718351 files and directories currently installed.)
Preparing to unpack .../steam_1%3a1.0.0.48-1ubuntu3_i386.deb ...
dpkg: error processing archive /var/cache/apt/archives/steam_1%3a1.0.0.48-1ubuntu3_i386.deb (--unpack):
 subprocess new pre-installation script returned error exit status 30
Installation terminated: Steam License Agreement was DECLINED.
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

How to accept the steam license and install steam via apt-get install steam? There was no popup information, no selection to make. It just defaults to declined.

I know I can download the deb file yet I want to use the repository.


4 Answers 4


This is supposed to work around the issue:

sudo apt purge steam steamcmd
sudo apt install steam steamcmd

I compiled these commands according to this bug tracker comment:

If you purge both steam and steamcmd and then do an apt install steam followed by an apt install steamcmd, both commands will succeed without errors.


When asked with options of I Accept or I Decline, use the and arrow keys to select I Accept

Then use TAB to select OK below the options

Finally, press ENTER.

  • The popup won't show up for this bug.
    – k0pernikus
    Dec 12, 2016 at 16:57
  • I experience the exact issue with you but the purge command that the others posted fixed it for me
    – bonesnatch
    Dec 14, 2016 at 3:44
  • I was able to hit Ok following this answer advice Jan 3, 2019 at 17:04

You can also "preseed" the answers to the license agreement via debconf so that it doesn't get hung up.



You have to scroll down and click "i agree" ,then 'continue'.

  • 1
    The popup won't show up for this bug.
    – k0pernikus
    Jun 13 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.