0

I got a video which was playing on the sender's laptop. When I downloaded it and tried playing using VLC, the duration of the video was shown as 0.00 with no error popping up.

I tried a file --mime-type filename.avi which gave the result as filename.avi: application/octet-stream.

I tried mediainfo filename.avi and the result was only the full name and the size information as below

General
Complete name           : filename.avi
File size               : 617 MiB

file filename.avi gives an output as filename.avi: data.

I have installed ubuntu-restricted-extras as well which doesn't help.

What could be the issue here? Is there any workaround for viewing this in VLC player? Or is there any player which I can try to play this video?

  • This looks like the video got corrupted during sending. Can you play other .avi files? – Michal Polovka Nov 29 '16 at 10:10
  • Like others mentioned already : file might have got corrupted during download. If you have downloaded from a torrent, it is also possible that the torrent is fake and the file you downloaded is a dummy data file. – kn_pavan Nov 29 '16 at 11:00
  • Yes able to play other .avi files. It was not a torrent download, the person which shared it with me has the video running in his laptop. He shared through cloud. – Sreeja Dec 1 '16 at 4:03
0

The video has possibly got corrupted while sending. To confirm this you can check the md5sum or sha256sum values of both the files. In case the file is corrupted, it would have different values than that of the original.

To check md5sum values open a terminal and go to the directory in which the file is located. Run md5sum filename.avi. This will produce the md5sum value of the file. Repeat the process for copied file. Alternatively, you can redirect the output to a file using md5sum filename.avi > md5dum.txt and then copy the file to the same location where the new file and check it there using md5sum -c md5sum.txt

  • Thank you for the suggestion. Unfortunately I got the file through multiple transmissions from a customer. Since I don't have direct contact, wont be able to request them to run a check. But I assume this is the issue. – Sreeja Dec 1 '16 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.