0

I cannot access the files in USB flash drive.

lsusb command lists the device:

Bus 002 Device 010: ID 1307:0163 Transcend Information, Inc. 256MB/512MB/1GB Flash Drive
...

However, it is not mounted automatically and I get the following error when I use mount command:

sudo mount -t vfat /dev/sdb /mnt/usb
mount: no medium found on /dev/sdb

How can I fix this issue?

I get the following output when I run

$ sudo lsblk -o NAME,LABEL
NAME   LABEL
sda
├─sda1 System Reserved
├─sda2
├─sda3
├─sda5
└─sda6
sr0

My operating system is Ubuntu 14.04.

2
  • Please run sudo lsblk -o NAME,LABEL or sudo parted -l from your terminal and post the output. – ThatGuy Nov 29 '16 at 6:01
  • @ThatGuy I added the output to the post above . – yildizabdullah Nov 29 '16 at 6:22
1

You should mount partitions, not the drive itself. Please try with the following commands (and let it find the file system automatically), for example

sudo mount /dev/sda5 /mnt

But this partition might be your root partition, which is already mounted. I think you want to mount a partition on the drive b, /dev/sdb. The problem is that the drive is not recognized as a mass storage device (not seen by lsblk).

You can try in another USB port of the same computer, in another computer and with another operating system (another linux distro or Windows or MacOS). If still no luck, I think your USB flash drive is damaged. See this link and links from it for more details.

Pendrive lifetime

10
  • There is only sdb under /dev directory. – yildizabdullah Nov 29 '16 at 9:08
  • If there is only /dev/sdb and no partitions dev/sdb1 etc, the system does not see any partitions. Are there data in the drive, that you want to recover? Or can you create a new partition table with a partition with the FAT32 file system alias format the drive? Depending on the situation, there are different things to suggest. – sudodus Nov 29 '16 at 11:54
  • I want to recover the data on the drive. – yildizabdullah Nov 29 '16 at 14:00
  • I suggest that you get another USB pendrive of at least the same size, clone your drive to that drive, and do the recovery work on that drive. It reduces the risk, to damage your drive. As long as it can be seen as /dev/sdb (or /dev/sdc ...) there is good hope, that mkusb can read it in a cloning process. Otherwise you can try with ddrescue. So install mkusb as described at help.ubuntu.com/community/mkusb and try with the command line in the next comment. – sudodus Nov 29 '16 at 14:17
  • 1
    sudo -H mkusb /dev/sdb – sudodus Nov 29 '16 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.