So I see that this is actually a thing. There are several posts in forums that deal with this subject but none of the solutions that I've tried has worked.

Here is the thing. I have a Ubuntu 16.10 installed alongside Windows 10. There are two partitions that I envisioned as sort of transition rooms for file sharing among OSs. The thing is that I can't seem to make any changes to files on other partitions from Ubuntu.

Solutions that I've already tried:

sudo chmod -Rf 777 /media/user/partitionname
sudo chown -R user:user /media/user/paritionname
sudo chown -R user:user /dev/sda5
sudo chown user:user /dev/sda5
sudo chmod 777 /dev/sda5
sudo chmod 777 /media/user/partitionname

What I get is the following:

chown: changing ownership of '/media/user/partitionname': Read-only file system

Or something along those lines.

New folder and paste options are greyed out.

What I've already tried is changing every single permission option that I could find to read and change or read and modify.

Any help will be greatly appreciated!

PS: I would also appreciate a basic tutorial for solutions proposed :) I'm still learning! Thanks!

  • @muru: It looks like there's a deeper underlying issue that needs to be dealt with first since the file system is mounted read-only. – David Foerster Nov 29 '16 at 4:41
  • 2
    @DavidFoerster probably the old fastboot/unclean partition problem – muru Nov 29 '16 at 4:42
  • 3
    It looks like the file system in question is mounted "read-only". This is either because of a (non-default) configuration setting or because the file system driver thinks that there's something wrong with the file system and falls back to read-only to avoid damage. Could you please unmount the file system, open a terminal (Ctrl+Alt+F1), run udisksctl mount --block-device <DEVICE> (replace <DEVICE> with the path to the block device representing the partition with the file system in question, e. g. /dev/sda5) and edit your question to include its output? Thanks. – David Foerster Nov 29 '16 at 4:46

As you have Dual boot system, then I think you should unlock the NTFS partition first from Windows. Then you will be able to Read and Write in the Partition. I did the following. Hope it will help you too.

To do that-

  1. Boot into Windows 10.
  2. Open My computer.
  3. Right-click the hard drive or partition you want to unlock and click "Properties."
  4. Head to the "Security" tab and click the "Advanced" button.
  5. Click "Continue" in the User Account Control window.
  6. Click your user name in the user list.
  7. Select the "Edit" button to add access permissions for your user.
  8. Click your user name and then click the "Allow" check box for "Full Control."
  9. Click "OK," "Yes" and "OK" again.
  10. The drive is now unlocked.
| improve this answer | |
  • This can all be done from within Ubuntu/Linux. No need to resort to Windows for that. This site is called “AskUbuntu” after all. ;-] Nonetheless the underlying issue here is not one of permissions but one of a write-protected file system, so -1. – David Foerster Nov 29 '16 at 5:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.