1

I've done nothing out of the usual today except for uninstalling and reinstalling Python 3, and performing apt update, apt full-upgrade, and apt autoremove as usual. But a few things are broken now:

  • Ctrl+Shift+t brings up XTerm, not my regular terminal.

  • My Vim formatting has disappeared.

  • On launching Pycharm, it needed to perform first-time setup before, even though I've used it on this install many times.

  • Firefox seems to be working normally, except that its icon has gone missing.

What did I do wrong?

Edit: Wow. I removed a lot of things. From /var/log/apt/history.log:

Start-Date: 2016-11-28  10:56:13
Commandline: apt remove python3
Requested-By: benjamin (1000)
Install: libgoa-backend-1.0-1:amd64 (3.18.3-1ubuntu2, automatic), gnome-control-center-data:amd64 (1:3.18.2-1ubuntu6, automatic), gnome-control-center:amd64 (1:3.18.2-1ubuntu6, automatic), realmd:amd64 (0.16.2-2, automatic), gnome-icon-theme:amd64 (3.12.0-1ubuntu3, automatic), libdleyna-connector-dbus-1.0-1:amd64 (0.2.0-1, automatic), gnome-settings-daemon:amd64 (3.18.2-0ubuntu3.1, automatic), iio-sensor-proxy:amd64 (1.1-1, automatic), gnome-icon-theme-symbolic:amd64 (3.12.0-1, automatic), dleyna-server:amd64 (0.4.0-1, automatic), gnome-online-accounts:amd64 (3.18.3-1ubuntu2, automatic), libdleyna-core-1.0-3:amd64 (0.4.0-1, automatic), libcolord-gtk1:amd64 (0.1.26-1, automatic), libgupnp-dlna-2.0-3:amd64 (0.10.4-1, automatic), libgupnp-av-1.0-2:amd64 (0.12.8-1, automatic)
Remove: python3-pexpect:amd64 (4.0.1-1), webaccounts-extension-common:amd64 (0.5-0ubuntu2.14.04.1), python3-defer:amd64 (1.0.6-2build1), python3-dev:amd64 (3.5.1-3), hplip-data:amd64 (3.16.3+repack0-1), python3-roman:amd64 (2.0.0-2), python3-html5lib:amd64 (0.999-4), python3-cupshelpers:amd64 (1.5.7+20160212-0ubuntu2), libgksu2-0:amd64 (2.0.13~pre1-6ubuntu8), python3-piston-mini-client:amd64 (0.7.5-0ubuntu2), unity-scope-firefoxbookmarks:amd64 (0.1+13.10.20130809.1-0ubuntu1), update-manager-core:amd64 (1:16.04.4), gedit:amd64 (3.18.3-0ubuntu4), unity-scope-virtualbox:amd64 (0.1+13.10.20130723-0ubuntu1), software-center-aptdaemon-plugins:amd64 (0.1.6build1), dropbox:amd64 (2015.10.28), python3-mako:amd64 (1.0.3+ds1-1ubuntu1), python3-software-properties:amd64 (0.96.20.4), apt-xapian-index:amd64 (0.47ubuntu8.3), foomatic-db-compressed-ppds:amd64 (20160212-0ubuntu1), python3-xkit:amd64 (0.5.0ubuntu2), update-notifier-common:amd64 (3.168.2), apturl-common:amd64 (0.5.2ubuntu11.1), python3-jwt:amd64 (1.3.0-1), onboard:amd64 (1.2.0-0ubuntu5), python3-systemd:amd64 (231-2build1), ubuntu-system-service:amd64 (0.3), snapd:amd64 (2.16ubuntu3), printer-driver-foo2zjs:amd64 (20151024dfsg0-1ubuntu1), update-manager:amd64 (1:16.04.4), printer-driver-postscript-hp:amd64 (3.16.3+repack0-1), python3-urllib3:amd64 (1.13.1-2ubuntu0.16.04.1), python3-aptdaemon.gtk3widgets:amd64 (1.1.1+bzr982-0ubuntu14), language-selector-common:amd64 (0.165.4), python3-reportlab-accel:amd64 (3.3.0-1), snap-confine:amd64 (1.0.43-0ubuntu1~16.04.1), python3-gi-cairo:amd64 (3.20.0-0ubuntu1), gnome-software:amd64 (3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1), usb-creator-common:amd64 (0.3.2), ubuntu-standard:amd64 (1.361), python3-brlapi:amd64 (5.3.1-2ubuntu2.1), python3-pil:amd64 (3.1.2-0ubuntu1), python3-pip:amd64 (8.1.1-2ubuntu0.4), python3-wheel:amd64 (0.29.0-1), gnome-orca:amd64 (3.18.2-1ubuntu3), plainbox-provider-resource-generic:amd64 (0.23-1), ubuntu-desktop:amd64 (1.361), python3:amd64 (3.5.1-3), python3-pyatspi:amd64 (2.18.0+dfsg-3), python3-louis:amd64 (2.6.4-2), xdiagnose:amd64 (3.8.4.1), python3-idna:amd64 (2.0-3), printer-driver-pxljr:amd64 (1.4+repack0-4), python-software-properties:amd64 (0.96.20.4), unity-scope-manpages:amd64 (3.0+14.04.20140324-0ubuntu1), unity-scope-colourlovers:amd64 (0.1+13.10.20130723-0ubuntu1), usb-creator-gtk:amd64 (0.3.2), flashplugin-installer:amd64 (11.2.202.644ubuntu0.16.04.1), rhythmbox-plugins:amd64 (3.3-1ubuntu7), plymouth-theme-ubuntu-text:amd64 (0.9.2-3ubuntu13.1), python3-six:amd64 (1.10.0-3), unity:amd64 (7.4.0+16.04.20160906-0ubuntu1), google-earth-stable:amd64 (7.1.7.2600-r0), ttf-mscorefonts-installer:amd64 (3.4+nmu1ubuntu2), unity-scope-zotero:amd64 (0.1+13.10.20130723-0ubuntu1), unity-lens-photos:amd64 (1.0+14.04.20140318-0ubuntu1), oneconf:amd64 (0.3.9), software-properties-gtk:amd64 (0.96.20.4), python3-uno:amd64 (1:5.1.4-0ubuntu1), unity-scope-gdrive:amd64 (0.9+16.04.20151125-0ubuntu1), python3-requests:amd64 (2.9.1-3), python3-httplib2:amd64 (0.9.1+dfsg-1), unity-scope-yelp:amd64 (0.1+13.10.20130723-0ubuntu1), python3-plainbox:amd64 (0.25-1), checkbox-converged:amd64 (1.2.4-0ubuntu1), python3-cups:amd64 (1.9.73-0ubuntu2), unity-control-center:amd64 (15.04.0+16.04.20160705-0ubuntu1), python3-pyparsing:amd64 (2.0.3+dfsg1-1ubuntu0.1), python3-xlsxwriter:amd64 (0.7.3-1), python3-xapian1.3:amd64 (1.3.4-0ubuntu1), python3-renderpm:amd64 (3.3.0-1), apturl:amd64 (0.5.2ubuntu11.1), python3-xdg:amd64 (0.25-4), python3-pycurl:amd64 (7.43.0-1ubuntu1), virtualenv:amd64 (15.0.1+ds-3), aisleriot:amd64 (1:3.18.2-1ubuntu1), ubuntu-minimal:amd64 (1.361), apport:amd64 (2.20.1-0ubuntu2.1), rhythmbox-plugin-zeitgeist:amd64 (3.3-1ubuntu7), nautilus-share:amd64 (0.7.3-2ubuntu1), ubuntu-drivers-common:amd64 (1:0.4.17.2), python3-speechd:amd64 (0.8.3-1ubuntu3), python3-cryptography:amd64 (1.2.3-1), python3-distupgrade:amd64 (1:16.04.18), gksu:amd64 (2.0.2-9ubuntu1), unity-scope-home:amd64 (6.8.2+16.04.20160212.1-0ubuntu1), python3-commandnotfound:amd64 (0.3ubuntu16.04.2), ubuntu-software:amd64 (3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1), python3-update-manager:amd64 (1:16.04.4), ubuntu-release-upgrader-core:amd64 (1:16.04.18), python3-apport:amd64 (2.20.1-0ubuntu2.1), hplip:amd64 (3.16.3+repack0-1), system-config-printer-gnome:amd64 (1.5.7+20160212-0ubuntu2), python3-cffi-backend:amd64 (1.5.2-1ubuntu1), unity-scope-openclipart:amd64 (0.1+13.10.20130723-0ubuntu1), plainbox-provider-checkbox:amd64 (0.25-1), unity-scope-calculator:amd64 (0.1+14.04.20140328-0ubuntu1), python3-docutils:amd64 (0.12+dfsg-1), python3-markupsafe:amd64 (0.23-2build2), ufw:amd64 (0.35-0ubuntu2), ibus-table:amd64 (1.9.1-3ubuntu2), python3-blinker:amd64 (1.3.dfsg2-1build1), ubuntu-core-launcher:amd64 (1.0.43-0ubuntu1~16.04.1), unity-control-center-signon:amd64 (0.1.8+16.04.20160201-0ubuntu1), inkscape:amd64 (0.91-7ubuntu2), checkbox-gui:amd64 (1.2.4-0ubuntu1), system-config-printer-udev:amd64 (1.5.7+20160212-0ubuntu2), python3-pkg-resources:amd64 (20.7.0-1), compiz-gnome:amd64 (1:0.9.12.2+16.04.20160823-0ubuntu1), ibus-pinyin:amd64 (1.5.0-3ubuntu3), libgnome-2-0:amd64 (2.32.1-5ubuntu1), python3-guacamole:amd64 (0.9.2-1), dh-python:amd64 (2.20151103ubuntu1.1), openprinting-ppds:amd64 (20160212-0ubuntu1), totem-plugins:amd64 (3.18.1-1ubuntu4), python3-gst-1.0:amd64 (1.6.2-1build1), libpurple-bin:amd64 (1:2.10.12-0ubuntu5.1), rhythmbox-plugin-magnatune:amd64 (3.3-1ubuntu7), compiz:amd64 (1:0.9.12.2+16.04.20160823-0ubuntu1), qml-module-io-thp-pyotherside:amd64 (1.4.0-2), python3-dbus:amd64 (1.2.0-3), python3-kivy-common:amd64 (1.9.1-2~stable0+201608272111~pkg135~ubuntu16.04.1), software-center:amd64 (16.01+16.04.20160420), python3-aptdaemon.pkcompat:amd64 (1.1.1+bzr982-0ubuntu14), ibus:amd64 (1.5.11-1ubuntu2), python3-cairo:amd64 (1.10.0+dfsg-5build1), python3-aptdaemon:amd64 (1.1.1+bzr982-0ubuntu14), lsb-release:amd64 (9.20160110ubuntu0.2), apport-gtk:amd64 (2.20.1-0ubuntu2.1), ubuntu-release-upgrader-gtk:amd64 (1:16.04.18), libgnomevfs2-common:amd64 (1:2.24.4-6.1ubuntu1), python3-gi:amd64 (3.20.0-0ubuntu1), python3-crypto:amd64 (2.6.1-6build1), python3-tk:amd64 (3.5.1-1), python3-ptyprocess:amd64 (0.5-1), unattended-upgrades:amd64 (0.90ubuntu0.2), gir1.2-ibus-1.0:amd64 (1.5.11-1ubuntu2), python3-oauthlib:amd64 (1.0.3-1), firefox:amd64 (50.0+build2-0ubuntu0.16.04.2), xul-ext-webaccounts:amd64 (0.5-0ubuntu2.14.04.1), apparmor:amd64 (2.10.95-0ubuntu2.5), python3-pygments:amd64 (2.1+dfsg-1), command-not-found:amd64 (0.3ubuntu16.04.2), python3-kivy-bin:amd64 (1.9.1-2~stable0+201608272111~pkg135~ubuntu16.04.1), lsb-core:amd64 (9.20160110ubuntu0.2), aptdaemon:amd64 (1.1.1+bzr982-0ubuntu14), libgnomevfs2-0:amd64 (1:2.24.4-6.1ubuntu1), python3-jinja2:amd64 (2.8-1), unity-scope-tomboy:amd64 (0.1+13.10.20130723-0ubuntu1), python3-checkbox-support:amd64 (0.22-1), language-selector-gnome:amd64 (0.165.4), system-config-printer-common:amd64 (1.5.7+20160212-0ubuntu2), python3-kivy:amd64 (1.9.1-2~stable0+201608272111~pkg135~ubuntu16.04.1), python3-reportlab:amd64 (3.3.0-1), python3-debian:amd64 (0.1.27ubuntu2), printer-driver-ptouch:amd64 (1.4-1), onboard-data:amd64 (1.2.0-0ubuntu5), python3-lxml:amd64 (3.5.0-1build1), python3-gdbm:amd64 (3.5.1-1), gnome-terminal:amd64 (3.18.3-1ubuntu1), unity-scope-texdoc:amd64 (0.1+14.04.20140328-0ubuntu1), unity-scope-devhelp:amd64 (0.1+14.04.20140328-0ubuntu1), unity-scope-chromiumbookmarks:amd64 (0.1+13.10.20130723-0ubuntu1), pipelight-multi:amd64 (0.2.8.2~ubuntu14.04.1), sessioninstaller:amd64 (0.20+bzr150-0ubuntu4.1), python3-padme:amd64 (1.1.1-2), python3-oneconf:amd64 (0.3.9), update-notifier:amd64 (3.168.2), python3-chardet:amd64 (2.3.0-2), python3-problem-report:amd64 (2.20.1-0ubuntu2.1), gconf2:amd64 (3.2.6-3ubuntu6), python3-virtualenv:amd64 (15.0.1+ds-3), libgnome2-common:amd64 (2.32.1-5ubuntu1), printer-driver-foo2zjs-common:amd64 (20151024dfsg0-1ubuntu1), python3-apt:amd64 (1.1.0~beta1build1), python3-setuptools:amd64 (20.7.0-1), libgnomevfs2-extra:amd64 (1:2.24.4-6.1ubuntu1), rhythmbox:amd64 (3.3-1ubuntu7), pyotherside:amd64 (1.4.0-2), rhythmbox-plugin-cdrecorder:amd64 (3.3-1ubuntu7), python3-bs4:amd64 (4.4.1-1), python3-pyasn1:amd64 (0.1.9-1), python3-feedparser:amd64 (5.1.3-3build1), gnome-menus:amd64 (3.13.3-6ubuntu3.1), software-properties-common:amd64 (0.96.20.4)
End-Date: 2016-11-28  10:57:44
1

This answer prompted me to run:

sudo apt install ubuntu-desktop

which fixed everything. That was really easy compared to how badly I seem to have screwed things up. I forgot python3 is a system python for Ubuntu...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.