3

I recently purchased an Acer C720P and installed Ubuntu 16.04 64bit (using Unity) on it. I did a full installation (not using Crouton). Everything works perfectly - except for the touchpad. The touchscreen works fine.

I've tried various fixes that I've found from Googling but nothing seems to make any difference, ex:

I've read things that say synaptics won't work, use libinput, and I've read things saying libinput won't work, use synaptics drivers. I've tried uninstalling all packages for one and installing the other. Same results after reboot. The touchscreen always works fine, and the touchpad has no response at all.

synclient gives the output Couldn't find synaptics properties. No synaptics driver loaded, and I do not see a touchpad tab under System Settings > Mouse & Touchpad.

Linux peppy 4.4.0-47-generic #68-Ubuntu

xinput:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ HP HP Link-5 micro dongle                 id=12   [slave  pointer  (2)]
⎜   ↳ Atmel maXTouch Touchscreen                id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ HP HP Link-5 micro dongle                 id=11   [slave  keyboard (3)]
    ↳ HD WebCam                                 id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=15   [slave  keyboard (3)]
    ↳ HP HP Link-5 micro dongle                 id=16   [slave  keyboard (3)]

Is there anyone who has gotten this working, or can point me in the correct direction?

1

From some posts I found on Reddit, it seems that your touchpad is probably Elantech. It may also be true, that the touchpad and keyboard multiplex through the i8042 chip.

I'd suggest adding the i8042.reset kernel parameter. This resets the controller when starting, which may be able to disable multiplexing mode if Linux does not correctly support it.

  1. sudo nano /etc/default/grub
  2. Add i8042.reset to the GRUB_CMDLINE_LINUX_DEFAULT= line like this: GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset quiet splash"
  3. sudo update-grub

Then reboot.

  • GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset quiet splash" No luck, touchpad still isn't doing anything. Looking around the Reddit thread to see what else there is. – neilsimp1 Dec 5 '16 at 2:53
  • Also, on askubuntu.com/questions/763584/…, xinput for this person actually says Elan Touchpad. Mine only has Virtual core pointer, which I have to assume is the touchpad. – neilsimp1 Dec 5 '16 at 3:02
1

Got it working.

Found the answer on https://ubuntuforums.org/showthread.php?t=2303936&highlight=acer+c720p

Installed kernel 4.1.6-galliumos_30_amd64 from https://galliumos.org/apt/pool/main/l/linux-upstream/, rebooted, and the touchpad suddenly works. It's a bit sensitive and tapping it doesn't register as a click, but it's a start.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.