1

I have ubuntu 16.04.1 LTS. After installing system I made this:

  • update-alternatives --remove python /usr/bin/python2
  • update-alternatives --install /usr/bin/python python /usr/bin/python3

But now I cannot update the system, programms and packages, because of this problem:

sudo apt-get dist-upgrade

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово

Расчёт обновлений… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 6 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить? [Д/н] y
Настраивается пакет python-gi (3.20.0-0ubuntu1) …
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при обработке пакета python-gi (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет alacarte:
 alacarte зависит от python-gi (>= 3.0), однако:
  Пакет python-gi пока не настроен.

dpkg: ошибка при обработке пакета alacarte (--configure):
 проблемы зависимостей — оставляем не настроенным
Настраивается пакет python-cairo (1.8.8-2) …
Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
                                                                                                           Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при обработке пакета python-cairo (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет python-gi-cairo:
 python-gi-cairo зависит от python-gi (= 3.20.0-0ubuntu1), однако:
  Пакет python-gi пока не настроен.
 python-gi-cairo зависит от python-cairo, однако:
  Пакет python-cairo пока не настроен.

dpkg: ошибка при обработке пакета python-gi-cairo (--configure):
 проблемы зависимостей — оставляем не настроенным
Настраивается пакет python-gobject-2 (2.28.6-12ubuntu1) …
Отчёты apport не записаны, так достигнут MaxReports
                                                   Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при обработке пакета python-gobject-2 (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Отчёты apport не записаны, так достигнут MaxReports
                                                   dpkg: зависимости пакетов не позволяют настроить пакет python-gobject:
 python-gobject зависит от python-gi (>= 3.20.0-0ubuntu1), однако:
  Пакет python-gi пока не настроен.
 python-gobject зависит от python-gobject-2, однако:
  Пакет python-gobject-2 пока не настроен.

dpkg: ошибка при обработке пакета python-gobject (--configure):
 проблемы зависимостей — оставляем не настроенным
Отчёты apport не записаны, так достигнут MaxReports
                                                   Обрабатываются триггеры для libc-bin (2.23-0ubuntu4) …
При обработке следующих пакетов произошли ошибки:
 python-gi
 alacarte
 python-cairo
 python-gi-cairo
 python-gobject-2
 python-gobject
E: Sub-process /usr/bin/dpkg returned an error code (1)

Help me plz to solve the problem.

0

Undo your changes using

sudo update-alternatives --remove  python /usr/bin/python3 
sudo ln -s python2 /usr/bin/python

See Why isn't python 3 the default python binary? for why you shouldn't change /usr/bin/python

3
  • Now I cannot run Terminal and "Programm updater"
    – A.K
    Nov 28 '16 at 9:52
  • @A.K, Ctrl+Alt+f1 to go tty1 console then Ctrl+Alt+f7 to go back to GUI
    – user.dz
    Nov 28 '16 at 10:39
  • I installed terminatorx. But how to fix all dependencies?
    – A.K
    Nov 28 '16 at 11:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.