0

I've researched far and wide on why I can't enter the disk decryption password at boot up, and though I've found some other similar questions to mine, I haven't found any solutions. It seems others who have experienced this have either solved it without responding how, or they've just given up.

I have both a disk decryption password and a desktop unlock password to enter with every boot. I originally installed Ubuntu 14.04, and after several OS updates, things started to act buggy (my display started to get screwed up, etc) and I eventually caved on Ubuntu's incessant reminders of upgrading to 16.04.

Once that was done, only some of my display issues were "healed" (still some bugs upon boot up), but the biggest issue is now my disk decryption splash screen will not take a password. I used to be able to enter a password and see the dots enter in the text field for the password, but I can't get anything to type there now.

I have to either hard reboot the system by holding down the power button, or holding CTRL+ALT+DELETE to knock me back to the GRUB boot screen where I will eventually get to a simple console (black background with white console font) where I'm prompted for my decryption password and I can successfully unlock the disk. (I should also mention that at this point, there are two errors displayed: 1) TPM error, cannot read pcr value 2) Something about not being able to find/read "ubuntu-vg".)

Like I say, this may seem like a duplicate of others on here, but their problems either weren't exactly the same as mine, or the solutions they were given didn't work.

I kinda don't want to just have it default to "nosplash" (which didn't work when I edited the grub file). I really want the install to run as intended!

I've heard there was v16.10 coming out that's supposed to fix some of these issues, but I haven't found the update - nor do I know if it will fix this.

This is the disk unlock splash screen (NOTE: This used to show dots for each character typed. Now it doesn't respond to keyboard actions and it does not record a password when typed, even without the echo). Ubuntu disk decrypt splash screen

If I press CTRL+ALT+DEL, I am taken to the GRUB screen where I select "Ubuntu" to boot normally. Ubuntu GRUB Options

When I select "Ubuntu" to boot normally, I am presented with the following errors and a prompt to enter the disk decrypt password (which now works). The TPM error is followed by "unable to read pcr value". Ubuntu disk unlock in GRUB

2

I had the same issue after installing proprietary NVIDIA GPU driver. Disabling splash screen worked for me. I know this is not a complete solution, but I think this workaround might be helpful because it is better than using GRUB menu options on every system boot.

I edited /etc/default/grub file: removed quiet splash from the GRUB_CMDLINE_LINUX_DEFAULT parameter. Then run sudo update-grub. Now the splash screen is gone and and I see a prompt to enter disk encryption as on the last screenshot in the question.

I am running Ubuntu 17.04, Linux kernel 4.10, NVIDIA driver 375.39.

  • Great find. What I did was leaving "quiet" in there, so it's easier to see the prompt coming up. I'm using nvidia 381.09. – Berend de Boer Apr 24 '17 at 6:53
  • How did you install the NVIDIA driver? – gtr1971 Apr 26 '17 at 21:30
  • 1
    I simply enabled Using NVIDIA binary driver ... option in System Settings - Software & Updates - Additional Drivers. I don't remember doing anything special to install it. – alxersov Apr 28 '17 at 19:42
0

It's normal for password requests not to echo back anything as you type, so some nearby onlooker can't see your password. Continue typing your known password, and if it's the correct password, it'll let you pass.

For now you can ignore the TPM error, at this point it's probably just noise from the Trusted Platform Module software. Later, we may decide to reinstall the TPM software if problems still exist.

I'd be concerned about the not being able to find/read "ubuntu-vg" error message. The first thing I'd do is a fsck (file system check) on your boot device. I normally have a predefined script on how to do this, but I'm not familiar with troubleshooting LVM disks, so I'm going to give you a modified process that should do the same job...

  • boot to the GRUB screen
  • choose Advanced Options
  • choose to run the fsck process

Report back.

  • Thanks for you response. I updated my post above to include screen caps of the errors I'm getting with a little more explanation. Sorry if I wasn't clear the first time, but when I get the splash screen with the password field, even if I type a password - it doesn't respond upon hitting <ENTER>. So no echo of dots (which it used to do) and no response after a CR. The only way to unlock the disk is to CTRL+ALT+DEL and enter the decrypt password at the GRUB prompt. ... I tried your steps above and they also did not work. – gtr1971 Nov 28 '16 at 14:45
  • Thanks for the screenshots. When you did my steps, please detail exactly what you did, and what you saw, after you started the fsck. In the Unity dashboard, type lvm and see if you find an app called Logical Volume Management. If you do, start it, and see if your disk/partition information looks correct to you. If you don't see this app, in terminal, type sudo apt-get update, then sudo apt-get install system-config-lvm, and then try again. I'll have to admit, that LVM and disk encryption are not my area of expertise, so we may have to rely on other experts to chime in. – heynnema Nov 28 '16 at 15:34
  • On an encrypted system, this error is completely normal. Before the drive is decrypted, LVM will be unable to see the container. Once the drive is decrypted, LVM will catch the existence of the device and then work. – Kaz Wolfe Oct 5 '17 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.