0

So I have a UEFI system from 2013, fast boot is disabled and all that, and secure boot is turned off. I just burned a fresh copy of Boot Repair Disk since I don't have a USB thumb drive, but my system doesn't detect the disk drive as being bootable. Nothing in the EFI firmware shows the optical disk drive as a boot option before I even get anything up. I opened up the disk in Windows Explorer to see that the disk does have an EFI folder and EFI boot files. So what's the problem?

  • Is your question really "how do I make my computer boot from DVD?" – WinEunuuchs2Unix Nov 27 '16 at 23:43
  • No, the question is "why won't boot-repair boot on my UEFI computer". I have a similar problem doing this. – heynnema Nov 27 '16 at 23:53
  • @heynnema Sorry it would have helped had OP stated all other DVD's boot ok. I can empathize because I all kinds of problems trying to get Live USB to boot but Live DVD booted no problem. – WinEunuuchs2Unix Nov 28 '16 at 0:05
  • Try changing your BIOS from UEFI mode, to CSM/Legacy and see if the Boot Repair disc will boot. Set your BIOS back to the setting you found it in when you're done. – heynnema Nov 28 '16 at 0:11
  • If I set the BIOS to CSM and boot, then try and fix the boot if it works, will it write grub to an MBR record? – Duke Wellington Nov 28 '16 at 3:27
3

You'll need to set your BIOS back to UEFI to boot your normal operating systems.

If for some reason that doesn't allow you to boot normally, then you'll need to run boot-repair in UEFI mode.

  • make sure your BIOS is set back to UEFI
  • boot a Ubuntu Live DVD in Try Ubuntu mode
  • make sure that you're connected to the Internet
  • start the terminal application from the Unity launcher
  • in the terminal, type:

    sudo add-apt-repository ppa:yannubuntu/boot-repair
    sudo apt-get update
    sudo apt-get install -y boot-repair
    sudo boot-repair

Perform the recommended repair.

  • Comments are not for extended discussion; the entire conversation that was taking place here has been moved to chat. – Thomas Ward Dec 1 '16 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.