0

I am following the instructions on RunningKVM.

My host runs Ubuntu Server 14.04.1 (64 bit)

I downloaded the Ubuntu Server ISO file:

wget -c http://old-releases.ubuntu.com/releases/14.04.2/ubuntu-14.04.1-server-amd64.iso

And then I ran:

qemu-img create -f qcow2 vdisk.img 10G
qemu-system-x86_64 -hda vdisk.img -cdrom ubuntu-14.04.1-server-amd64.iso -boot d  -m 384

Error:

Could not initialize SDL(No available video device) - exiting

From what I understand, this is because I am not running it from X windows machine.

Then, after googling, I added -vga none and I ran:

qemu-system-x86_64 -vga none -hda vdisk.img -cdrom ubuntu-14.04.1-server-amd64.iso -boot d  -m 384

And again I got the same error.

Then I ran with -nographic:

qemu-system-x86_64 -nographic  -hda vdisk.img -cdrom ubuntu-14.04.1-server-amd64.iso -boot d  -m 384

And this was stuck without any error (I waited over 10 minutes). So I had to kill this process from a different machine.

What is the correct way to install when the host does not have x windows with this setup?

  • Have you tried qemu -curses? You may also want to try running gksudo qemu-system-x86_64 <switches> as well – ThatGuy Nov 28 '16 at 2:43
  • I had just tried qemu -curses... – Kevin Wilson Nov 28 '16 at 5:28
  • Poke: three weeks past by. Any ideas about the answer ? – Kevin Wilson Dec 13 '16 at 12:30
  • My previous comment from 28 of November was not sent fully, so I am repeating it in full: I had just tried qemu -curses, and I see one line on a black screen, saying: 1024x 768 Graphic mode (in blue). And I cannot do anything from this screen, – Kevin Wilson Dec 13 '16 at 16:05
0

Try with -vga qxl (you must modprobe the qxl module first), or -vga virtio.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.