I am using Ubuntu 16.10, and I only installed virtualenv using aptitude. After creating a new environment, and listed installed packages using pip freeze I am always getting the output of

pkg-resources==0.0.0

This is causing issues when I try to deploy my Django app to other systems. What am I doing wrong?

Note that I am getting this issue only in Ubuntu and not in other distros that I tried so far.

Thanks for helping me out in advance.

up vote 7 down vote accepted

According to https://stackoverflow.com/a/40167445/486919 and https://stackoverflow.com/a/40167000/486919, this is a bug on Ubuntu's end and a bug report has been made at https://bugs.launchpad.net/ubuntu/+source/python-pip/+bug/1635463. Consider clicking on "Does this bug affect you?" followed by "Yes, it affects me" to bring this bug to the maintainers' attention.

For the time being, as stated in https://stackoverflow.com/a/40167445/486919, you can use pip freeze with grep -v to create requirements.txt that you can subsequently use with pip install -r:

pip freeze | grep -v "pkg-resources" > requirements.txt
  • Thanks a lot, i though i was doing something wrong on my side :) – georoot Nov 27 '16 at 17:05
  • 1
    @georoot No problem, I hadn't noticed this bug until I saw your question, so I learned something new too! – edwinksl Nov 27 '16 at 17:08
  • 1
    Irritatingly still a thing 2 years later. I no longer see "Does this bug affect you" at the indicated link, perhaps because of the status change to Confirmed since you posted. – Two-Bit Alchemist Dec 1 at 16:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.