7

I am using Ubuntu 16.10, and I only installed virtualenv using aptitude. After creating a new environment, and listed installed packages using pip freeze I am always getting the output of

pkg-resources==0.0.0

This is causing issues when I try to deploy my Django app to other systems. What am I doing wrong?

Note that I am getting this issue only in Ubuntu and not in other distros that I tried so far.

Thanks for helping me out in advance.

1 Answer 1

9

According to https://stackoverflow.com/a/40167445/486919 and https://stackoverflow.com/a/40167000/486919, this is a bug on Ubuntu's end and a bug report has been made at https://bugs.launchpad.net/ubuntu/+source/python-pip/+bug/1635463. Consider clicking on "Does this bug affect you?" followed by "Yes, it affects me" to bring this bug to the maintainers' attention.

For the time being, as stated in https://stackoverflow.com/a/40167445/486919, you can use pip freeze with grep -v to create requirements.txt that you can subsequently use with pip install -r:

pip freeze | grep -v "pkg-resources" > requirements.txt
3
  • Thanks a lot, i though i was doing something wrong on my side :)
    – georoot
    Commented Nov 27, 2016 at 17:05
  • 1
    @georoot No problem, I hadn't noticed this bug until I saw your question, so I learned something new too!
    – edwinksl
    Commented Nov 27, 2016 at 17:08
  • 1
    Irritatingly still a thing 2 years later. I no longer see "Does this bug affect you" at the indicated link, perhaps because of the status change to Confirmed since you posted. Commented Dec 1, 2018 at 16:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .