4

a weird sound problem appeared after a do-release-upgrade (14.04 -> 16.04): After upgrade, sound output through HDMI/pulseaudio (which used to work just fine before) works erratically: sometimes there's no sound at all even if the pavucontrol panel displays output levels as if everything was ok (if I select/configure HDMI output and play anything with mplayer for instance, it shows the volume level bar bouncing, but no sound from speakers).

sometimes after a reboot, without changing anything to the sound settings, sound is really coming from HDMI output! right now, I can't hear a thing from the HDMI output, but pavucontronl looks like this: pavucontrol screen capture as playing a mp3 file

and here is the output of pacmd list-sinks, as I'm trying to play the same file, no sound actually produced yet...

pacmd list-sinks
1 sink(s) available.
  * index: 15
    name: <alsa_output.pci-0000_00_03.0.hdmi-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: RUNNING
    suspend cause: 
    priority: 9950
    volume: front-left: 62850 /  96% / -1,09 dB,   front-right: 62850 /  96% / -1,09 dB
            balance 0,00
    base volume: 65536 / 100% / 0,00 dB
    volume steps: 65537
    muted: no
    current latency: 178,02 ms
    max request: 36 KiB
    max rewind: 64 KiB
    monitor source: 17
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
                 Stéréo
    used by: 1
    linked by: 1
    configured latency: 210,00 ms; range is 0,50 .. 371,52 ms
    card: 0 <alsa_card.pci-0000_00_03.0>
    module: 2
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "HDMI 0"
        alsa.id = "HDMI 0"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "3"
        alsa.card = "0"
        alsa.card_name = "HDA Intel HDMI"
        alsa.long_card_name = "HDA Intel HDMI at 0xaa134000 irq 49"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:03.0"
        sysfs.path = "/devices/pci0000:00/0000:00:03.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "160c"
        device.product.name = "Broadwell-U Audio Controller"
        device.form_factor = "internal"
        device.string = "hdmi:0"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "hdmi-stereo"
        device.profile.description = "Digital Stereo (HDMI)"
        device.description = "Audio interne Digital Stereo (HDMI)"
        alsa.mixer_name = "Intel Broadwell HDMI"
        alsa.components = "HDA:80862808,80860101,00100000"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: yes)
            properties:
                device.icon_name = "video-display"
                device.product.name = "PLB2403WS"
    active port: <hdmi-output-0>

I checked the HDMI cable, tried to use another hdmi source on the same hdmi monitor: definitely not a hardware pb. No such trouble using the analogic output so far.

I read this thread and tried to apply the same recipes (speaker-test using hdmi related devices does not produce any sound, works well with analogic (PCH) device) so it doesn't seem to be a default sampling rate pb.

It rather looks like a lower level hdmi module problem, though snd_hda_codec_hdmi is loaded, and I'm stuck there, trying to guess. Any idea is welcome! :-)

  • Another user and myself are working on a similar problem now: askubuntu.com/questions/854055/… – WinEunuuchs2Unix Nov 27 '16 at 15:43
  • 1
    I think it's a bit different, I'm not even trying to switch back and forth between analog and hdmi output, it's just that sometimes hdmi output looks like doing OK (from pavucontrol POV), but no sound is really physically produced by the output device, and sometimes (after a reboot for instance), it's just fine. It really works randomly. weird... – the_dude Dec 2 '16 at 20:26

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.