2

I have recently installed ubuntu 14.04. I have downloaded the driver of my printer from here because in the "printers" drivers menu the driver for EPSON L355 does not appear.

When I try to install the drivers I get this error

vladimir@qubit:~/Documents/Programs/epson_printer_drivers$ sudo dpkg -i epson-inkjet-printer-201207w_1.0.0-1lsb3.2_i386.deb 
Selecting previously unselected package epson-inkjet-printer-201207w.
(Reading database ... 215943 files and directories currently installed.)
Preparing to unpack epson-inkjet-printer-201207w_1.0.0-1lsb3.2_i386.deb ...
Unpacking epson-inkjet-printer-201207w (1.0.0-1lsb3.2) ...
dpkg: dependency problems prevent configuration of epson-inkjet-printer-201207w:
 epson-inkjet-printer-201207w depends on lsb (>= 3.2).

dpkg: error processing package epson-inkjet-printer-201207w (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 epson-inkjet-printer-201207w

I have no idea how to fix this. I've tried some solutions involving the package alien, as well as gdebi, but I can't succeed. I'm a bit desperate by now, so any help is very much appreciated.

Also, checking my lsb gives:

vladimir@qubit:~/Documents/Programs/epson_printer_drivers$ lsb_release -a
LSB Version:    core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:cxx-4.0-amd64:cxx-4.0-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-3.1-amd64:desktop-3.1-noarch:desktop-3.2-amd64:desktop-3.2-noarch:desktop-4.0-amd64:desktop-4.0-noarch:desktop-4.1-amd64:desktop-4.1-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.0-amd64:graphics-3.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch:graphics-4.1-amd64:graphics-4.1-noarch:languages-3.2-amd64:languages-3.2-noarch:languages-4.0-amd64:languages-4.0-noarch:languages-4.1-amd64:languages-4.1-noarch:multimedia-3.2-amd64:multimedia-3.2-noarch:multimedia-4.0-amd64:multimedia-4.0-noarch:multimedia-4.1-amd64:multimedia-4.1-noarch:printing-3.2-amd64:printing-3.2-noarch:printing-4.0-amd64:printing-4.0-noarch:printing-4.1-amd64:printing-4.1-noarch:qt4-3.1-amd64:qt4-3.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.5 LTS
Release:    14.04
Codename:   trusty
  • I had this problem back when 14.04 LTS was first released, then I switched from distro but came back on a new computer and Ubuntu install with 16.04 LTS. Not using this exact model but L455 and Epson drivers work OK now. – xangua Nov 27 '16 at 5:02
  • @xangua thanks but I decided to stick with ubuntu 14.04 – Vladimir Vargas Nov 27 '16 at 5:05
  • If that's your choice you could try opening the .deb file, search and extract the .PPD file to use it (you should be offer this option when setting a printer if no drivers are found). – xangua Nov 27 '16 at 5:13
1

OP accidentally tried to install 32bit driver, while using a 64bit OS.

OP installed the 64bit driver, and all was resolved.

  • I get exactly the same error :( – Vladimir Vargas Nov 27 '16 at 5:04
  • What about running sudo apt-get -f install? – ThatGuy Nov 27 '16 at 5:07
  • I've already done it, and if I run sudo dpkg -i epson..., the error appears again. – Vladimir Vargas Nov 27 '16 at 5:08
  • Can you run lsb_release -a please? – ThatGuy Nov 27 '16 at 5:09
  • The output is too long, so I appended it to the question – Vladimir Vargas Nov 27 '16 at 5:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.