0

I have a new laptop with Nvidia GTX 1070. After the grub menu and the splash screen the monitor goes black, but I can see the Ubuntu welcome sound.

I tied boot options like nomodeset, nouveau.modeset=0, text, forcevesa without any difference. However, it looks like there is a small chance that the monitor will go live. This allowed me to actually install the Ubuntu 16.10. And once I reached the login screen. After entering the password the screen freezed again.

I cannot get access to the virtual terminal (Ctrl + Alt + F1) either.

I want to try to install Nvidia proprietary drivers. Is there a way to boot to console only mode?

2
  • Does this (askubuntu.com/questions/38618/…) help? – Schwesi Nov 26 '16 at 21:49
  • @DavidFoerster The article suggest to use nomodeset instead of quiet splash boot options. I tried that, and it makes absolutely no difference. – chfast Nov 26 '16 at 22:12
2

The problem solved by disabling "hybrid" graphics in BIOS. Precisely, I found a switch in BIOS with options: MSHybrid (default) and DISCRETE. Selecting DISCRETE allowed be to login to Ubuntu. It looks like the problem is in Intel and Nvidia GPU cooperation, not in the Nvidia GPU itself.

1
  • Congratulations :-) Then you need not try special ways to run in text mode. Do you want me to remove my answers? – sudodus Nov 26 '16 at 22:54
0

I found this link:

ask.xmodulo.com/boot-into-command-line-ubuntu-debian.html

The boot option 'text' does not work for me or 'is not enough' in newer systems with systemd.

sudo nano /etc/default/grub

Look for a line that starts with GRUB_CMDLINE_LINUX_DEFAULT, and comment out that line by prepending # sign. This will disable the initial splash screen, and enable verbose mode(i.e., showing the detailed booting procedure).

Then change GRUB_CMDLINE_LINUX="" to:

GRUB_CMDLINE_LINUX="text"

Next, uncomment the line that says "#GRUB_TERMINAL=console".

Save and run

sudo update-grub

-o-

For systemd-enabled desktop

If your desktop uses systemd, and I am rather sure it does (Ubuntu 15.04 or later), there is one additional step needed. That is to change the default target from "graphical" target to "multi-user" target. Skip this step if your desktop does not use systemd.

sudo systemctl set-default multi-user.target

At this point, your desktop should boot into the command line when you reboot it.

-o-

You can always revert to desktop boot later by restoring GRUB config file and running:

sudo systemctl set-default graphical.target
3
  • To do all these changes I have to boot the system first. – chfast Nov 26 '16 at 22:06
  • You are right. Then there are problems ... but it should be possible to install and boot Ubuntu Server. It has no graphics, so you should get a text screen. after preparing/fixing, it should be possible to do the transfer to graphics mode. – sudodus Nov 26 '16 at 22:38
  • I made a second answer with a link to a system, where you download a compressed image file instead of an iso file. – sudodus Nov 26 '16 at 22:46
0

Another and probably better alternative is to install a system intended to be installed into USB drives, but it works in SSDs and HDDs too. Download a compressed image file instead of an iso file and install it by flashing like you do with a mobile phone, Raspberry Pi and other devices.

This system boots in UEFI as well as BIOS mode into a text mode menu, and from that menu you can select graphics mode. And you can exit to the bash shell and do the necessary tweaks until it works in graphics mode.

When you have made it work with boot options and proprietary drivers, you can install a full desktop environment and boot directly into it. See this link

Installation/UEFI-and-BIOS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.