1

This question already has an answer here:

I am trying to mount a Western Digital My Book (which I believe is formatted as NTFS) on an up-to-date version of Ubuntu 14.04. When I boot it up, it shows in Nautilus on the side as "My Book" under devices, but when I click on it, an error dialogue pops up stating:

Unable to access "My Book"

Error mounting /dev/sdc2 at /media/lesk/My Book: Command-line `mount -t "exfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,namecase=0,errors=remount-ro,umask=0077" "/dev/sdc2" "/media/lesk/My Book"' exited with non-zero exit status 32: mount: unknown filesystem type 'exfat'

Is there any patch for fixing this? There is already data stored on the My Book that I need (it was added to the My Book on a Windows 10 system) so reformatting it is not an option.

If there is no patch for 14.04 to fix this, would upgrading to 16.04.1 do this any good?

marked as duplicate by TheWanderer, Eric Carvalho, Pilot6, WinEunuuchs2Unix, Zanna Nov 27 '16 at 17:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Do you have extfat-fuse and extfat-utils installed? If not, it might help to install them with sudo apt-get install exfat-fuse exfat-utils – Evan Chen Nov 26 '16 at 21:21
0

Connect the WD drive back into a Windows environment, and note which drive letter it's assigned. Then in an administrative command prompt window, type:

chkdsk /f x:

replacing the "x" with the assigned drive letter for the WD.

When you're done, make sure that you properly eject the drive from Windows, using the green USB icon in the system tray, before pulling the plugs.

Not the answer you're looking for? Browse other questions tagged or ask your own question.