0

I'm using Ubuntu 16.04, with this hardware:

# E2400 Killer Ethernet
lspci -nn | grep 0200
04:00.0 Ethernet controller [0200]: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller [1969:e0a1] (rev 10)

And this version of ubuntu:

Linux lilezek-desktop 4.4.0-47-generic #68-Ubuntu SMP Wed Oct 26 19:39:52 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

alx's modinfo:

# modinfo alx 
filename:       /lib/modules/4.4.0-47-generic/kernel/drivers/net/ethernet/atheros/alx/alx.ko
license:        GPL
description:    Qualcomm Atheros(R) AR816x/AR817x PCI-E Ethernet Network Driver
author:         Qualcomm Corporation, <nic-devel@qualcomm.com>
author:         Johannes Berg <johannes@sipsolutions.net>
srcversion:     80B89D6BA6F4A4F4A917E3C
alias:          pci:v00001969d000010A0sv*sd*bc*sc*i*
alias:          pci:v00001969d000010A1sv*sd*bc*sc*i*
alias:          pci:v00001969d00001090sv*sd*bc*sc*i*
alias:          pci:v00001969d0000E0A1sv*sd*bc*sc*i*
alias:          pci:v00001969d0000E091sv*sd*bc*sc*i*
alias:          pci:v00001969d00001091sv*sd*bc*sc*i*
depends:        mdio
intree:         Y
vermagic:       4.4.0-47-generic SMP mod_unload modversions 

More info about ALX and ifconfig:

# ifconfig
enp5s0    Link encap:Ethernet  direcciónHW ::ec  
      ACTIVO DIFUSIÓN MULTICAST  MTU:1500  Métrica:1
      Paquetes RX:0 errores:0 perdidos:0 overruns:0 frame:0
      Paquetes TX:0 errores:0 perdidos:0 overruns:0 carrier:0
      colisiones:0 long.colaTX:1000 
      Bytes RX:0 (0.0 B)  TX bytes:0 (0.0 B)
      Interrupción:16 

# lsmod | grep alx
alx                    36864  0
mdio                   16384  1 alx

# dmesg | grep alx
[   21.416362] alx 0000:05:00.0 eth1: Qualcomm Atheros AR816x/AR817x Ethernet [1c:1b:0d:68:96:ec]
[   21.440970] alx 0000:05:00.0 enp5s0: renamed from eth1

# dmesg | grep enp
[  113.422322] alx 0000:05:00.0 enp5s0: NIC Up: 100 Mbps Full
[  113.554797] alx 0000:05:00.0 enp5s0: fatal interrupt 0x200, resetting
[  113.556538] alx 0000:05:00.0 enp5s0: NIC Up: 100 Mbps Full
[  113.689014] alx 0000:05:00.0 enp5s0: fatal interrupt 0x200, resetting
[  113.690728] alx 0000:05:00.0 enp5s0: NIC Up: 100 Mbps Full
# unplug cable    
[  113.796813] alx 0000:05:00.0 enp5s0: Link Down
[  113.823228] alx 0000:05:00.0 enp5s0: fatal interrupt 0x200, resetting
[  113.957444] alx 0000:05:00.0 enp5s0: fatal interrupt 0x200, resetting
[  114.091661] alx 0000:05:00.0 enp5s0: fatal interrupt 0x200, resetting
[  114.201293] IPv6: ADDRCONF(NETDEV_UP): enp5s0: link is not ready
[  114.225878] alx 0000:05:00.0 enp5s0: fatal interrupt 0x200, resetting
[  114.360092] alx 0000:05:00.0 enp5s0: fatal interrupt 0x200, resetting
[  114.494306] alx 0000:05:00.0 enp5s0: fatal interrupt 0x200, resetting

Which is updated. Everything was working but I changed my motherboard which had a Gigabit Ethernet Controller to a new motherboard with E2400 Killer Ethernet Controller.

Could it be that changing the hardware is making Ubuntu not to work properly?

Regards, lilEzek.

  • What does this teminal command tell us: modinfo alx | grep E0A1 – chili555 Nov 26 '16 at 16:55
  • Check again the question. – lilezek Nov 26 '16 at 21:27
  • Does the module load? lsmod | grep alx If not, load it: sudo modprobe alx Is an interface created? ifconfig Are there any clues in the log? dmesg | grep alx – chili555 Nov 26 '16 at 22:33
  • I'm sorry about the lack of info. I'm not used to have problems with the drivers. – lilezek Nov 27 '16 at 14:10
  • Everything looks entirely normal so far! Let's look at the log as you are trying to connect: dmesg | grep enp And also: sudo ethtool enp5s0 As the result will be lengthy, please paste the results here and give us the link: paste.ubuntu.com – chili555 Nov 27 '16 at 16:59
1

Please see this post: https://forums.linuxmint.com/viewtopic.php?t=215169 The poster has the same symptoms; a not-working ethernet and the error message:

fatal interrupt 0x200, resetting

He solved it by disabling IOMMU is the BIOS. Please try it. If it is ineffective, we'll try the GRUB parameter option.

Please open a terminal and do:

gksudo gedit /etc/default/grub

Use nano or kate or leafpad if you don't have the text editor gedit. Change the line:

GRUB_LINUX_CMD_LINE=""

To read:

GRUB_LINUX_CMD_LINE="iommu=soft"

Proofread carefully, save and close the text editor. Get the system to re-read the file and use the changes:

sudo update-grub

You should be all set.

  • IOMMU is enabled. If I disable IOMMU I lose USB control. No USB works with IOMMU disabled with this motherboard. Any idea? – lilezek Nov 30 '16 at 15:31
  • I have fixed it by disabling IOMMU, and then setting iommu=soft on GRUB option. I upvote you because it was very useful and I'll choose your answer as correct if you add the iommu=soft boot option to your answer. – lilezek Nov 30 '16 at 18:27
  • Please see my edit above. I'm glad it's fixed. – chili555 Nov 30 '16 at 22:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.