1

As I was upgrading to Ubuntu 16.04, I noticed that it removed libapache-mpm-itk. After the upgrade, I ran apache2ctl configtest to see if it would pass.

The first error I encountered "cannot load libphp5.so" and so I purged it and installed libphp, which installed php7. So far so good.

The next error was expected:

AH00526: Syntax error on line 4 of /etc/apache2/sites-enabled/nsc.local.conf: Invalid command 'AssignUserID', perhaps misspelled or defined by a module not included in the server configuration

Note that I had been successfully using the mpm before upgrading.

So, the next logical thing to do is install the Apache 2 ITK MPM:

sudo apt-get update && sudo apt-get install libapache2-mpm-itk

but... it didn't change anything. I still get the same error. Any ideas where to go from here?


FYI info:

$ apache2 -v
Server version: Apache/2.4.18 (Ubuntu)
Server built:   2016-07-14T12:32:26

$ sudo apt-get update && sudo apt-get install libapache2-mpm-itk
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Hit:2 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Hit:3 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease             
Get:4 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]  
Fetched 204 kB in 0s (373 kB/s)                                                
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libapache2-mpm-itk is already the newest version (2.4.7-04-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


$ ls /etc/apache2/mods-enabled/
access_compat.load  autoindex.load  mpm_prefork.conf  proxy.load
alias.conf          deflate.conf    mpm_prefork.load  rewrite.load
alias.load          deflate.load    negotiation.conf  setenvif.conf
auth_basic.load     dir.conf        negotiation.load  setenvif.load
authn_core.load     dir.load        php7.0.conf       socache_shmcb.load
authn_file.load     env.load        php7.0.load       ssl.conf
authz_core.load     filter.load     proxy.conf        ssl.load
authz_host.load     headers.load    proxy_html.conf   status.conf
authz_user.load     mime.conf       proxy_html.load   status.load
autoindex.conf      mime.load       proxy_http.load   xml2enc.load
3
  • Do you see the module in the output of ls /etc/apache2/mods-enabled/?
    – user508889
    Commented Nov 26, 2016 at 15:03
  • post updated with output
    – Tim Morton
    Commented Nov 26, 2016 at 18:08
  • Your question helped me. I had sudo a2enmod mpm_itk down, but forgot all about sudo apt-get install libapache2-mpm-itk. Commented May 25, 2017 at 14:20

1 Answer 1

0

You don't appear to have mpm_itk.load in your mods-enabled folder, which most likely indicates it's not loaded.

sudo a2enmod mpm_itk
sudo service apache2 restart
1
  • 1
    Bingo! I got the following warnings: $ sudo a2enmod mpm_itk Considering dependency mpm_prefork for mpm_itk: Considering conflict mpm_event for mpm_prefork: Considering conflict mpm_worker for mpm_prefork: Module mpm_prefork already enabled Enabling module mpm_itk. But, that took care of the problem.
    – Tim Morton
    Commented Nov 26, 2016 at 21:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .