I have a new computer with Ubuntu 16.04 LTS installed.

When launching firefox, I have to wait several minutes for the start page to appear. I just have this:

enter image description here

Once I'm finally on the start page, the navigation is perfectly normal. I tried to reinstall firefox and to run it on safemode, but none of these solved my problem. I first thought it was a connection problem, but it's not, since Chromium works just fine.

  • Did you check this? Theres a few answers you could try askubuntu.com/questions/333720/firefox-very-slow?rq=1 – M. Becerra Nov 26 '16 at 15:04
  • Is it only Firefox? Or do other browsers take a long time to load as well? – You'reAGitForNotUsingGit Nov 26 '16 at 15:05
  • @M.Becerra yes I tried these, but it does not change anything. It's just that it takes a long time to start. After this, firefox works fine. – Augustin Nov 26 '16 at 15:09
  • @AndroidDev I have no problem with chromium. I could just use chromium, but I'd like to understand what's going on with firefox. – Augustin Nov 26 '16 at 15:09
  • @Augustin - Have you done sudo apt-get upgrade and sudo apt-get dist-upgrade? – You'reAGitForNotUsingGit Nov 26 '16 at 15:10

I admit this to be an oddball answer but here I find I need to reboot my DSL Router when connectivity to the outside world slows down: Firefox, ansiweather (Terminal-based weather utility), etc. To me everything in the Router's web pages look fine -- 40-50% memory usage, etc. Boot the Router and I'm back to full speed for another month or so. HTH.


I'm not sure what the cause is, but you can install something to make apps start up faster.

Preload, as you can tell by the name, preloads all of your apps so they will start faster. Also, check your startup applications and uncheck the ones you don't want to run on startup. This will make Ubuntu in general a bit faster. If you want to install it, open a terminal and type sudo apt install preload


You can change nice ness value for firefox which will imporve its performance

  • Welcome to Ask Ubuntu! I recommend to edit your question to expand it with specific details about what you do. – abu_bua Oct 8 '18 at 13:32

I had the same problem. To solve it, I changed my DNS server settings and now everything gets resolved really fast (apt update, Firefox startup, git, etc.).

Change DNS server settings:

If you are using a wired network, go to Ubuntu Settings > Network > Wired > Options > IPv4. Make sure IPv4 Method is Automatic (DHCP) and choose your DNS server (I personally use You can do the same for IPv6, make sure to put a valid IPv6 to the DNS server.

wired config

If you are using a Wireless connection, go to Ubuntu Settings > Wireless > [YourWifi] > Options and follow the same instructions.


In my personal experience, I managed to speed up Firefox (and overall looking my entire PC as well) using software called BleachBit. You can find it in Ubuntu Software.

After installation, you'll be asked to enter your username's password. After that you're left with a powerful software that can clean your APT (Advanced Packaging Tool), Bash history, Deep scan, Firefox (everything from backup files, caches, cookies, passwords and even URL history), Flash caches and cookies, LibreOffice cache and history... But most importantly, you can perform some amazing System cleaning (I personally recommend that option).

I used an options called "Free disk space" which overwrites free disk space to hide deleted files and "Memory" which wipes the swap and free memory. It improved my overall system speed.

Much luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.