I've installed Ubuntu 10.04 on an USB drive a few days ago, and have been mostly using linux since them (but I`ve been able to start windows properly after using the pen drive linux).

Now, I guess I've got two problems. I'm not sure both would fit this forum, but as I suspect the first might have caused the later, here they go:

  • Today, when I tried to restart my computer and boot Windows from internal HDD NTFS partition, I got a blue screen with error code 0x0024 (a lot more 0's there), saying a problem was detected and Windows has been shutdown to prevent damage, etc... no useful information. I couldn't even boot in the safe mode. My first thought was I might still be able to access the windows file system from linux, what took me to the next problem:
  • After booting ubuntu from the USB drive, I tried to access the windows filesystem from GUI menu "Places -> 54GB Filesystem", but it says "according to mtab /dev/sda2 is already mounted on /media/227C59C27C599181". Trying to mount from the command line also doesn't work, it says sda2 is already mounted on wherever I try to mount it. Trying to open /etc/mtab says "Input/Output error". I noticed the following error message on dmesg: "EXT2-fs error (device loop1): ext2_lookup: deleted inode referenced: 98399."

Is it possible that a disk partition failure may have caused the /etc/mtab damage?
Can I recover/repair the /etc/mtab file? How?

Additionally, I also tried booting with a Windows XP install disk (not the same I've on my disk, as that is still factory installed), hoping I could use the system repair option. The windows installation system recognized my hard drive, all partitions are shown correctly, except that for the C partition the filesystem type is displayed as "unknown".

Thanks in advance, to anyone who can provide some advice on what I could do to solve either of these problems.

UPDATE: I managed to fix my NTFS partition by running CHKDSK from HBCD, and now I can boot on windows again. However, I've not yet get back to linux to see if that would eventually solve to mtab issue too.


No, mtab wouldn't have contributed to the fault. Though writing to your NTFS volume from Linux might, that support isn't full proof and can cause corruption. If you did that then I don't know what else I could recommend to you except to get Windows to run chkdsk and cross your fingers. It's either that or the drive itself is failing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.