2

My Ubuntu 14.04 system is out of sync when I compare date and hwclock. Hwclock is simply 3 hours behind the system clock. As I live in GMT+3 time zone. Sample output:

$ date
Sat Nov 26 13:18:40 +03 2016
$ sudo hwclock
Sat 26 Nov 2016 10:18:46 AM +03  -0.317417 seconds

So far solutions I tried:

  • hwclock --systohc
  • hwclock -w --localtime

None of these working, I mean it works until reboot. I also tried setting hwclock manually. Every time, I reboot my computer hwclock is 3 hours behind my sysclock. Is there a service manipulating time?

Other references I checked before I asking this question

  • Do you have another operating system installed in the machine (dual boot)? Or is this a virtual machine? – user.dz Nov 26 '16 at 11:04
  • No it's the only OS installed on an old laptop. – emrecnl Nov 26 '16 at 11:07
  • Could you edit the question and add the content of /etc/default/rcS and the output of sudo hwclock --debug – user.dz Nov 26 '16 at 11:17
  • What is the output of timedatectl? – Terrance Nov 27 '16 at 2:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.