3

Tried

$ sudo add-apt-repository ppa:hanipouspilot/rtlwifi
$ sudo apt-get update
$ sudo apt-get install rtlwifi-new-dkms linux-firmware

But giving

whiplash@whiplash-HP-Notebook:~$ sudo apt-get install rtlwifi-new-dkms    
Reading package lists... Done    
Building dependency tree           
Reading state information... Done    
E: Unable to locate package rtlwifi-new-dkms

My wireless card details:

*-network
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 00
       serial: a8:a7:95:23:cb:25
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.8.0-27-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:17 ioport:3000(size=256) memory:a1100000-a1103fff
  • As i see here the package rtlwifi-new-dkms isn't available for Ubuntu 16.10 (Yakkety). The latest Ubuntu version that is supported by this PPA repository is 16.04 (Xenial). I think you should download the package for Ubuntu 16.04 and force dpkg to install it. Be careful about this solution. Maybe it causes broken dpkg database! – SuB Nov 26 '16 at 8:34
  • 2
    You already have drivers for your wifi, is there a problem? – Jeremy31 Nov 26 '16 at 12:58
  • As @Jeremy31 says, you already have a driver. Installing an older version not written specifically for your kernel version is unlikely to help. Please tell us what problem you are having. – chili555 Nov 26 '16 at 14:04
  • 1
    The problem is I should sit very close to the router, or else due to weak signal strength I can't connect to the wifi. The issue is with the weak signal strength – Stonecipher Nov 26 '16 at 15:25
  • 1
    You can build the drivers manually by following instructions mentioned in answer to this question askubuntu.com/questions/590414/… I have successfully tried them in Ubuntu 16.10. – coolbootgeek Dec 29 '16 at 11:47
1

I maintain the hanipouspilot PPA. That is why I can give the best answer ;-)

I did not upload an rtlwifi-new-dkms package for Yakkety 16.10.

You can try to download the deb for Xenial, but it is unlikely that it will build for the 4.8 kernel. I did not test it.

The reason is simple. I do not use this release and I can't test the module.

You can try to use a driver from https://github.com/lwfinger/rtlwifi_new

  • Are you going to upload soon for Yakkety 16.10? – Stonecipher Nov 26 '16 at 15:18
  • Or should I roll back to 16.04 LTS? – Stonecipher Nov 26 '16 at 15:29
  • I did not plan to support yakkety in my PPA. Probably I will do it some time, but no promise. – Pilot6 Nov 26 '16 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.