1

Simply put, I am adding strings to a script that I run upon login to spoof my MAC address for anonymity. I have installed macchanger on my Ubuntu 16.04 machine and I am experimenting with it from the command line before adding the lines so the script.sh.

When I run ifconfig | grep HWaddr I get the following output:

enp3s0    Link encap:Ethernet  HWaddr xx:31:50:5f:21:xx  
wlo1      Link encap:Ethernet  HWaddr xx:26:c7:a9:e2:xx

After some looking around I understood that wlo1 is my Network Adapter that needs spoofing (I am not sure what enp3s0 is at this moment).

This is how I proceeded to change my MAC address (unsuccessfully):

sudo service network-manager stop  
sudo ifconfig wlo1 down  
sudo macchanger -a wlo1

At this point my MAC address is changed because the output is:

Current MAC:   xx:26:c7:a9:e2:xx (Intel Corporate)  
Permanent MAC: xx:26:c7:a9:e2:xx (Intel Corporate)  
New MAC:       00:26:0d:15:d0:62 (Mercury Systems, Inc.)

I proceed with:

sudo ifconfig wlo1 up  
sudo service network-manager start

And then when I check the MAC address, it was reset to it's original state:

$ ifconfig | grep HWaddr  
enp3s0    Link encap:Ethernet  HWaddr xx:31:50:5f:21:xx  
wlo1      Link encap:Ethernet  HWaddr xx:26:c7:a9:e2:xx

What am I doing wrong?

  • I found out that enp3s0 is my Ethernet interface. – UnixForce Nov 25 '16 at 23:16
  • After a couple hours of research it appears to be impossible to spoof a MAC address on Ubuntu 16.04... Ubuntu is disapointing. – UnixForce Nov 26 '16 at 0:17
0

Try ifconfig but not all drivers let you change your MAC

sudo ifconfig wlo1 down
sudo ifconfig wlo1 hw ether 00:01:02:03:04:05
sudo ifconfig wlo1 up`
  • Although it allows me to change the MAC address, just like macchanger, it will not let me connect to the internet afterwards. You must be right, I will have to research my driver and see if it is, as you say, preventing me from establishing a www connection. – UnixForce Nov 28 '16 at 23:41
  • Your access point might be using MAC filtering option – meccooll Nov 29 '16 at 4:49
  • I believe you are right, thank you. I will be looking further into this. – UnixForce Nov 29 '16 at 8:26
0

With the help of some searching in my router parameters, I came to the conclusion that some built-in "feature" of the router enabled the MAC address filtering of devices attempting to connect to the acess point.

I believe this filtering could potentially be blocking the connection to the network because of the new MAC adress assigned to my network interface.

The MAC addess was successfully changed with the above answers, only afterwards, my network was made unreachable due to the filtering. (When running ping www.google.com the only output was connect: Network is unreachable) It might also have to do with the connection being wireless.

I went to my routers configuration pannel and found no way of disabling the filter. My options are limited to replacing the router with one that either does not have a MAC address filtering restriction or has the option to turn it off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.