4

I recently bought an Acer Swift 3 ultrabook pre-loaded with Windows 10, which I wiped out to install Ubuntu 16.04.1 in single-boot. In my case installs are generally a breeze, but not this time. Long story short, I ended up with a «No Bootable Device» message on boot. I fixed the problem with Boot-Repair. The ultrabook now works perfectly.

After the repair, however, I kept getting at boot time a blue window with this message : « Default Boot Device Missing or Boot failed. Insert recovery media and hit any key ». Hitting a key would lead me to a Boot Manager with only one entry: 1- Windows boot manager. Selecting it would then get me to Grub, with the usual Ubuntu option.

I search the net, found the post Bootable device not found after clean install of Ubuntu 14.04 UEFI on Acer, modified the BIOS-settings as instructed («Select an UEFI file as trusted for executing» and so on), to no avail. The blue rectangle just won't go away at boot. The only change is that there is now a Ubuntu entry in the Windows Boot manager.

Secure Boot is enabled.

The boot priority order is:

  1. EFI File Boot 0 : Ubuntu
  2. Windows Boot Manager
  3. HDD : HF S256G39TND-N210A

By the way, when I modified the BIOS-Settings in the Security tab, I found three .efi files in HDDO - EFI - ubuntu. I selected the first one (as suggested), and left the other two untouched: grubx64.efi and MokManager.efi.

I could of course reinstall Ubuntu from scratch, but since I've already installed a whole bunch of applications, I’d rather find a workaround.

The output of sudo efibootmgr -v is:

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0001,0000,0002,2001,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,f7b03efc-87a7-467e-af43-862381b9c710,0x800,0x100000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* ubuntu    PciRoot(0x0)/Pci(0x17,0x0)/Sata(1,0,0)/HD(1,GPT,f7b03efc-87a7-467e-af43-862381b9c710,0x800,0x100000)/File(\EFI\ubuntu\fwupx64.efi)A01 ..
Boot0002* Unknown Device:   HD(1,GPT,f7b03efc-87a7-467e-af43-862381b9c710,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot2001* EFI USB Device    RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network   RC
1
  • 1
    Please type sudo efibootmgr -v in a Terminal window in Ubuntu. You should then either edit your question to cut-and-paste the output there, adding four spaces to the start of each line; or post the output to a pastebin site and post the URL to your document here.
    – Rod Smith
    Nov 25 '16 at 20:57
3

The solution to my problem was found by user oldfred, from the Ubuntu forums.

Can't get rid of «Default Boot Device Missing» message on boot

From the output of sudo efibootmgr -v he deduced that:

It looks like your default UEFI boot entry 0001 is fwupx64.efi which is the grub menu entry to get into UEFI. If you have secure boot on, you want to boot shimx64.efi which is 0002 but shown as unknown device.

On his advice I went back into UEFI and set "trust" and a label on the shimx64.efi file.

Et voilà!

0

I am giving you two links with answers for your Swift 3 troubles. How to get GRUB boot option? see both the answers in this question and the comments as well.

there are two parts to this. Part 1 - getting Ubuntu with a mainline 4.12 and above kernel and installing it part 2 - enabling secure boot, adding your efi file as secure, disabling secure boot, and making grub come on top of the boot list.

good luck ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.