0

Unable to install flash player on Ubuntu 16.04.

  1. I tried locating on Software Center. Didn't help. No good results on Soft Center

  2. Tried updating Ubuntu. Didn't help. Screen I get when I tried #1 comment suggestion

  3. Tried going through the process of downloading .tar.gz from Adobe. That didn't help either.

  4. I tried all three steps on wikihow. Didn't worked for me.

What should I do?

[Update:] This might help. When I tried running command sudo apt-add-repository multiverse && sudo apt-get update, I get the following message: N: Ignoring file '50unattended-upgrades.ucf-old' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension

1
  • Comments are not for extended discussion; the entire conversation has been moved to chat.
    – Thomas Ward
    Nov 28, 2016 at 23:07

1 Answer 1

0

This is a known problem in 16.04 that happens because /var/lib/update-notifier/package-data-downloads/partial/ is owned by root:root but apt drops privileges and runs as user _apt when downloading files.

More details and a quick fix on launchpad:

sudo chown _apt:root /var/lib/update-notifier/package-data-downloads/partial/
sudo rm /var/lib/update-notifier/package-data-downloads/partial/*.FAILED
sudo apt install --reinstall update-notifier-common

To get rid of the warning:

N: Ignoring file '50unattended-upgrades.ucf-old' in directory '/etc/apt/apt.conf.d/'

Remove file /etc/apt/apt.conf.d/50unattended-upgrades.ucf-old, more information can be found in another askubuntu.com question.

5
  • Encountered error on second command. postimg.org/image/luiwnzkst
    – Doherty
    Nov 25, 2016 at 18:35
  • The command tries to remove a file that does not exist, this is not a problem...
    – mgor
    Nov 25, 2016 at 18:37
  • I ran third command, (the install -reinstall update ) one. I got this screen. postimg.org/image/7eachda5d It talks about N:ignoring a file
    – Doherty
    Nov 25, 2016 at 18:42
  • Instead of taking screenshots of text, you should use one of the pastebins, wiki.ubuntu.com/Pastebin. Also, did you even read the whole answer? As you can see, the original warning and problems of downloading the files was fixed and to get rid of the last warning, read the answer again.
    – mgor
    Nov 25, 2016 at 18:53
  • Sorry, I apologize for screenshots. It's just that I had been trying to solve this since last few weeks. I was sharing screenshots at every point to ensure that I didn't miss any relevant information, that could help this problem to be solved. I won't do it again. And, yes, I did read your answer. I did even visit the another thread whose link you have shared. I tried removing the file, but it seems that it doesn't exist. I am still exploring further to see if I did miss anything
    – Doherty
    Nov 25, 2016 at 18:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.