3
Device          Start        End   Sectors   Size Type
/dev/sda1        2048    1050623   1048576   512M EFI System
/dev/sda2     1050624  837228543 836177920 398.7G Linux filesystem
/dev/sda3  1452748800 1465147391  12398592   5.9G Linux swap
/dev/sda4   837228544 1452748799 615520256 293.5G Microsoft basic data

Partition table entries are not in disk order.


Disk /dev/sdb: 14.6 GiB, 15636364800 bytes, 30539775 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00378159


Device     Boot Start      End  Sectors  Size Id Type
/dev/sdb1  *     2048 30539774 30537727 14.6G  c W95 FAT32 (LBA)

I am kinda lost here. I am not very experienced with ubuntu and might need a little detailed solution. I installed Windows 10 after ubuntu 16.10 and when I try to reinstall grub2 and it gives me the following error: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing? Please help!

  • Please detail the procedure used. – kyodake Nov 25 '16 at 13:54
  • Ok so I run the Following commands: mount /dev/sda1 /boot/efi and it mounts. when I run: apt-get install --reinstall grub-efi it gives me this output: – Evion Cane Nov 25 '16 at 13:59
  • The following NEW packages will be installed: grub-common grub-efi grub-efi-amd64 grub-efi-amd64-bin grub2-common 0 upgraded, 5 newly installed, 0 to remove and 196 not upgraded. Need to get 2,534 B/2,996 kB of archives. After this operation, 16.4 MB of additional disk space will be used. Do you want to continue? [Y/n] y – Evion Cane Nov 25 '16 at 14:00
  • 2
    You have to be consistent. You can install both Windows & Ubuntu in UEFI boot mode on gpt partitioned drive or both in BIOS boot mode on MBR(msdos) partitioned drive. But Windows only boots from gpt with UEFI and only with BIOS from MBR. And how you boot install media it then how it installs. So if you want UEFI, boot only in UEFI mode. help.ubuntu.com/community/UEFI If Boot-Repair is asking for a bios_grub partition then it is trying to make Ubuntu a BIOS boot on gpt drive. You then cannot have Windows in BIOS boot mode as drive is gpt. – oldfred Nov 25 '16 at 16:51
  • 1
    @EvionCane Please edit your question with the above information. It's nearly impossible to read in comment form. – wjandrea Nov 25 '16 at 21:30
1

Try this:

Boot the Ubuntu Live Usb-Dvd.

Open a terminal,

Press Ctrl+Alt+T

Run it:

sudo -i
mount /dev/sda2 /mnt
mount /dev/sda1 /mnt/boot/efi
grub-install --boot-directory=/mnt/boot --bootloader-id=ubuntu  --target=x86_64-efi --efi-directory=/mnt/boot/efi  
reboot
  • These commands must be run after booting into a live disc, right? – wjandrea Nov 25 '16 at 21:31
  • @wjandrea: Yes. For the user seemed to be clear, according to his proposal. I edit it in case it will be useful for someone else. – kyodake Nov 25 '16 at 23:37
  • grub-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory. – Evion Cane Nov 26 '16 at 20:27
  • that's that it says when I run the grub-install command – Evion Cane Nov 26 '16 at 20:27
  • worked like a charm! was little freaked out when I deleted my boot partition, but this did the trick. – Glenn Van Schil Mar 6 '18 at 17:34
1

The root cause of your problem is Temporary failure resolving 'al.archive.ubuntu.com This means that when you attempted this process the server was temporarily unavilable. You have 2 options.

1) Try again

2) Choose a different mirror By Opening Software & Updates and selecting a different server in the Download from drop down menu. (Choosing Other will run a series of tests to determine which is the best server for you.)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.