When i open nautilus it works fine until i change the window to another application, then it crash.

I try to start nautilus from terminal to see what happens and this is the output:

arturo@toto:~$ nautilus

(nautilus:4110): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed

(nautilus:4110): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed

(nautilus:4110): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed

(nautilus:4110): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(nautilus:4110): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
arturo@toto:~$ ^C

I try this solution from Nautilus not opening up, showing GLib error

arturo@toto:~$ ps aux | grep nautilus
arturo    1858  0.2  0.7 946456 59756 ?        Sl   10:20   0:06 nautilus -n
arturo    4176  0.0  0.0  16760  1012 pts/4    S+   11:12   0:00 grep --color=auto nautilus
arturo@toto:~$ sudo kill 1858
[sudo] password for arturo: 
arturo@toto:~$ nautilus -q
Initializing nautilus-dropbox 2.10.0

** (nautilus:4181): CRITICAL **: Another desktop manager in use; desktop window won't be created

(nautilus:4181): Gtk-CRITICAL **: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

also try purge and reinstall and nautilus remains the same.

also tried this sudo nautilus error in 16.04

with no succes

What can i do to have nautilus working just fine, i mean without crushing?

  • Could you edit the title and make clear what the question is? Thank you. – Andrea Lazzarotto Nov 24 '16 at 14:22
  • reboot & likely it'll be fine – doug Nov 25 '16 at 3:25
  • @doug not solved – Arturo Veras Nov 25 '16 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.