0

This question already has an answer here:

Every time I start any virtual machine it give's me error:

Kernel driver not installed (rc=-1908)The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing '/etc/init.d/vboxdrv setup'as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

I tried installing kernel driver again but no success. I'm using ubuntu 16.10 and really want that specific version 4.3

marked as duplicate by Andrea Lazzarotto, Eric Carvalho, WinEunuuchs2Unix, Ravan, TheWanderer Nov 25 '16 at 3:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Enable Insecure Boot – M. Becerra Nov 24 '16 at 13:50
  • @M.Becerra could you explain a bit? – Salman Saif Nov 24 '16 at 13:52
1

Secure boot is something new since 16.04. It's a feature to assure that no rogue software gets installed on your computer. It kind of mimics a similar thing from Windows OS. You can safely turn it off in Ubuntu, especially if you have to load custom drivers.

Boot your computer and enter the BIOS by hitting the appropriate function key (F2?) or DEL or ESC. Go to the security tab/section, and find secure boot and disable it. Exit the BIOS and reboot your computer and you should be fine. If not, you may still need to do a sudo /etc/init.d/vboxdrv setup in the terminal application.

Also note that there are newer versions of Virtualbox that you should install... v5.0 and v5.1.

  • There isn't any secure boot option in my security tab. and I specifically want that version because of Mac OS Yosemite. another thing is when I run from command line: WARNING: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (4.8.0-27-generic) or it failed to load. ( I think it is not supported for current kernel version) – Salman Saif Nov 24 '16 at 19:20
  • You're running a PC, yes? How does Mac OS figure in here? Anyway, the secure boot option is there, in your BIOS, somewhere. Different manufacturers do BIOS a little differently, so it's not always easy for a support person to say go here or go there. Just look around in your BIOS, and you'll find secure boot... if you're running a PC. – heynnema Nov 24 '16 at 19:37
  • I want to run Mac OS in virtualbox and i'm using PC running ubuntu 16.10 :) I installed it on my another PC running windows and it's working fine there – Salman Saif Nov 24 '16 at 19:42
  • Anyway, look again for the secure boot option in your BIOS. – heynnema Nov 24 '16 at 19:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.