1

I recently reinstalled my laptop with ubuntu gnome 16.10. I previously had 16.04 which was upgraded from 15.10, but this time I installed clean. My wifi-module works fine and I connect to networks successfully. On the first network, the internet is fine, but when I go to work for example (and thus switch wifi-network) I have to restart the network-manager for the internet to work. It will connect to the wifi-network, but the internet won't work.

Laptop: Dell XPS 13, 9350

EDIT 1: it doesn't (only?) happen after switching wifi, it happens everytime I suspend the laptop and unsuspend it (i.e. close the lid and open it again).

  • Check that your Network adapter has low power mode "enabled", this use to happen to me on a windows 8.1/10 machine when machine went into sleep or hibernate mode. – Blind TeamKiller Dec 1 '16 at 15:00
2
+50

Create a script that restarts your NetworkManager after suspend:

sudo gedit /etc/systemd/system/wifi-resume.service

Paste the following in it:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Now activate it:

sudo systemctl enable wifi-resume.service

From Wifi doesn't work after suspend after 16.04 upgrade but can't mark as dupe, credits to Joakim Koed.

  • It's not really a fix to the problem, more a hack around it, right? – Rien Heuver Dec 5 '16 at 9:40
  • @RienHeuver In the basest sense yes, it is a fix, but it also is a hack. Try it and see if it works for your needs. There aren't any concrete fixes, as this is a bug: bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1574347 – negusp Dec 5 '16 at 13:17
  • Well, it sort of fixes the problem. Thing is though, that my network-icon is no longer showing in my upper-right corner (Gnome). It's not a huge problem, but it's a nice thing to have when I want to switch networks quickly. (I know, I can access network-settings in other ways, but this is an issue to the fix either way.) – Rien Heuver Dec 5 '16 at 13:33
  • @RienHeuver What happens if you create a script that restarts the gnome-panel at wakeup? Follow the instructions here and instead of the example body add killall gnome-panel (make sure to end the script with esac!). – negusp Dec 5 '16 at 13:55
  • Does the network-icon really not work? I find that on my laptop, it disappears but will reappear if I click and hover around where it should be. – mcchots Dec 6 '16 at 7:34
0

Check for ubuntu 'network manager' set as "No Proxy" and open terminal

sudo service network-manager stop
sudo service network-manager start

Or you can do

sudo service network-manager restart

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.