0

UPDATE 11.24.16

Goal: Access Macintosh HD files (HFS+ volume) from Linux Live.

I started from scratch and created a bootable drive of 16.04.1. My Macintosh HD is mounted by default. I can now see files (could not before), but when I go to my User folder to access files, I receive a permission denied error.

I read that I need to mount the HFS+ drive as read/write (same as the commands I have used below). I am still not getting this to work though. I installed "hfsplus" and "hfsutils" since "hfprog" is no longer applicable in this version.

Any thoughts or suggestions? I have run the following code in this order:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install hfsplus
sudo apt-get install hfsutils
sudo lsblk -o NAME,FSTYPE,SIZE,MOUNTPOINT,LABEL
sudo mount -t hfsplus -o force,rw /dev/sda2 /media/mount_point

Regarding the last line of code above, I am a bit confused on the proper convention for the mount point. The lsblk code shows MOUNTPOINT as "/media/Ubuntu/Macintosh HD". Would the following code be correct:

sudo mount -t hfsplus -o force,rw /dev/sda2 /media/Ubuntu/Macintosh HD

Thanks again for the help.

I created a bootable USB of Ubuntu so I can boot into my friend's Mac and help them get their files before wiping the computer.

I am out of ideas on how to mount and access the HFS+ drive testing this out on my own MacBook Pro. I found instructions online to do the following:

sudo apt-get install hfsprog
sudo mount -t hfsplu -o force,rw /dev/sdx# /media/mntpoint

or

sudo mount -t hfsplus -o remount,force,rew /dev/sdx# /mount/point

If drive is partially corrupted:

sudo fsck.hfsplus /dev/sdx#

I was able to get hfsprogs installed but still not able to access the HDD. When I ran this code the Macintosh HD actually disappeared from my sidebar but still listed as mounted when I ran sudo lsblk -o NAME,FSTYPE,SIZE,MOUNTPOINT,LABEL

I tried gksudo nautilus command as well and a new file viewer window popped up but nothing else happened there either -- no "nautilus" folder, no access to the HDD.

I'm really frustrated and exhausted from trying to make this work for hours and still no success. Any thoughts?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.