After an update, the Nvidia drivers wrecked my machine, I tried all fixes I could but couldn't get it to work until I purged Nvidia and selected Noveau. However, my computer freezes randomly the monitor only shows diagonal broken lines. I can only restart it by pushing the power button. Any way of fixing this would be much appreciated.

this is what happens

After completing step 1 , I ran sudo apt-get update && sudo apt-get dist-upgrade from Terminal, where I got a bunch of errors. Of course, I have no clue whatsoever about their meaning.

So, from Terminal (normal boot) I ran $ sudo add-apt-repository --remove ppa:ubuntu-x-swat/x-updates and got a message saying I needed to downgrade. I used sudo ppa-purge ppa:ubuntu-x-swat/x-updates to downgrade and got an error saying it can't be done.

I continued with step 2, sudo add-apt-repository ppa:graphics-drivers/ppa with no errors. However after sudo apt-get update && sudo apt-get dist-upgrade I got a list of errors about not being able to fetch certain files. sudo apt-get install nvidia-304 nvidia-settings was error-free.

Method 1 did not work at all, I got stuck an the login loop.

After trying method 2 (manually purging, then installing only the 304 driver) had the same result: login loop.

However, when purging again from TTY (the only way to get access after installing nvidia) I got a message that caught my attention: it said it was removing nvidia settings 375 which I did not install. Could this be a clue?

enter image description here

Text (right side is cut off on some lines):

INFO:Disable nvidia-304
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_he…
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
update-initramfs: deferring update (trigger activated)
Purging configuration files for nvidia-304 (304.132-0ubuntu0.16.04.2) ..…
update-initramfs: deferring update (trigger activated)
Removing nvidia-opencl-icd-304 (304.132-0ubuntu0.16.04.2) ...
Purging configuration files for nvidia-opencl-icd-304 (304.132-0ubuntu0.1…
Removing nvidia-settings (375.20-0ubuntu0~gpu16.04.1) ...
Purging configuration files for nvidia-settings (375.20-0ubuntu0~gpu16.04…
Processing triggers for libc-bin (2.23-0ubuntu4) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for initramfs-tools (0.122ubuntu8.5) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-53-generic
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ..…
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...

After having access, I manually purged Nvidia from terminal, with this output. Seems to me it doesn't matter if I install only 304, a bunch of other stuff comes with it. Could this be the problem?

Why is it so complicated? The only issue I've had with Ubuntu in 6 years, is with the Nvidia drivers.

  • boot in recovery mode & install the old Nvidia drivers that worked – user613307 Nov 24 '16 at 5:36
  • @Vencen the old Nvidia driver I was using (304.132 legacy) didn't work at all. I have Noveau selected in "additional drivers" and that is the only way I could avoid the login loop, If i choose Nvidia 304 I get either flickering black screen or login loop. – Ghosts in my machine Nov 24 '16 at 14:38
  • @Vencen thanks for the edit, it is quite clear now, however I ran into a problem, added screenshots – Ghosts in my machine Dec 2 '16 at 1:47
  • @Vencen got more error messages, don't know if I should carry on with step 2... – Ghosts in my machine Dec 3 '16 at 17:59
  • @Vencen as per your instruction: found error. Stopped. – Ghosts in my machine Dec 5 '16 at 0:56

-if you can't boot normally or login successfully      

- boot why holding the Shift key or repeatedly pressing Esc until you see the GRUB menu
select advanced options
then recovery mode
select resume normal boot
then hit Enter
your'll be using the fail safe graphics drivers

More black screen help

- collect infomation

- In a terminal run

$ lspci -k | grep -EA2 'GA|3D' && dpkg -l | grep nvidia

Save the output to a text document

-Step 1   

- Resetting the system to the default open source drivers.

Manually purge all previously installed proprietary Nvidia drivers with this command

$ sudo apt-get purge --auto-remove nvidia-* libcuda-*

This is mandatory if they where previously installed & has be done every time when switching proprietary drivers .   ‍ 

Reboot ‍ ‍ ‍

-step 2

- Installing the latest proprietary Nvidia drivers

$ sudo add-apt-repository ppa:graphics-drivers/ppa

$ sudo apt-get update && sudo apt-get dist-upgrade

Automatically install the recommended driver like the "additional drivers" system would

$ ubuntu-drivers autoinstall

Done !

Reboot x2 all for changes to take affect

Then install nvidia-settings & reconfigure the Xorg servers settings

$ sudo apt-get install nvidia-settings && sudo nvidia-xconfig -v


- Try rebooting again, some times configuration files are missing or corrupted & need to be created,
rebooting allows the new configuration to take place.

If the problem persists (installing the latest driver did not work)
do step 1 again.
then continue to installation Method 1 or Method 2

In you saved text document find. ii nvidia-(you numbers here) make a note of those numbers

Method 1: Downgrading
Downgrade the driver. I.E. UnUpdate it.

Use the links for tutorials on how to downgrade

downgrade with APT ‍ & ‍ downgrade Graphically

Last command should look something like

$ sudo apt-get install nvidia-340=340.98-0ubuntu0

Reboot for changes to take affect

Selecting the recommended Nvidia driver in "additional drivers" afterwards will change the version & can cause problems

Method 2: manual choice
Manually choose an (older) driver version
check for driver versions that support you GPU
You can generate a list using-

simple list

$ apt-cache search '^nvidia-[:digit]' --names-only

complete list

$ apt-cache search '^nvidia-*'

install your Chosen version

$ sudo apt-get install nvidia-(your chosen version number) nvidia-settings

Note. no (brackets)

Then Reboot x2 for changes to take final affect

nvidia-settings is universal to all driver versions

The latest version of nvidia settings is 375. thats why it's installed, if the the new nvidia-settings is a problem don't install it, it just configures the graphics settings.

If it works ok then install nvidia-settings & reconfigure the Xorg servers settings

$ sudo apt-get install nvidia-settings && sudo nvidia-xconfig -v


- When you find a stable driver run this command. then you will never have this problem again.

$ sudo apt-mark hold nvidia-(your version number)

That way upgrading the system won't update the Nvidia driver.

Help on package holding

So complicated ? you're not the only One.


- Physical graphics card information & current GPU driver in use ‍ ‍ ‍ ‍

$ lspci -k | grep -EA2 'GA|3D' && dpkg -l | grep nvidia

$ ubuntu-drivers devices

Nvidia GPU's get legacy support after 10 years

ii = installed, nouveau = open source, nvidia = proprietary.

Google a lot & don't give up :)

  • Last time I did that, was when everything broke down. But, I'll give it a shot and post back. Do I need to select Nvidia in "additional drivers" afterwards? Thanks. – Ghosts in my machine Nov 25 '16 at 17:10
  • The additional drivers system is "smart" but not all knowing. – user613307 Nov 25 '16 at 19:33
  • here's the output: 'lspci -k | grep -EA2 'VGA|3D' 00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) Subsystem: Hewlett-Packard Company C61 [GeForce 6150SE nForce 430] Kernel driver in use: nouveau' – Ghosts in my machine Nov 28 '16 at 23:11
  • 1
    -1 Bad formatting/Markdown; way too many revisions (48 at the moment). I tried to edit this but gave up at the second paragraph inside an invalid HTML tag. Please revise this answer to make it more professional: 1) Label the sections. 2) If you need to edit to add more info, label the edit. 3) Use four spaces at the start of a line for code formatting. – wjandrea Dec 12 '16 at 7:44
  • 1
    @Vencen I did and tested for a couple of days. Everything is fixed now. I will edit my question accordingly and give you the "answered" thing after. Thanks for your assistance. – Ghosts in my machine Dec 30 '16 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.